Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Variables not updated in the worklfow

CIGM
Level 3
Level 3

Hi all,

I have a triggered workflow where the variables after the split are not being updated. Please see screenshot below:

1472471_pastedImage_0.png

I can see in the journal of the workflow that the data is updating correctly and the email is being sent because it's showing in the deliveries view. However, why the variables after the split are not being updated? They still have the numbers of the first time the email was sent to 371 people. I have cleared local cache and log out and log in again but still is showing no update in the variable.

Any help understanding why this happens would be appreciate it.

Best,

Carlota

3 Replies
florentlb
Level 10
Level 10

Hi Carlota,

If your workflow runs several time, I think you need to reinitialize the variables so they can update to the correct value at each execution.

Florent

CIGM
Level 3
Level 3

Hi Florent,

Thanks for your reply but I don't understand what you mean with your explanation. Could you please explain how to reinitialize the variables? Do you mean restart the workflow? If so, the whole point of having it triggered with an alert and an incremental query is not to have to re-start it each times this happens.

Thanks,

C

pablo_rosero1
Level 10
Level 10

Hi C,

I guess what Florent was trying to say, is that even though the workflow runs continuously, perhaps it's something that can be solved on your side by resetting the variables, only as needed of course, every time the workflow runs, to obtain the desired results.

All the best,

Pablo