Workflow in started state and Delivery in "Pending delivery" for days.

Avatar

Avatar
Give Back
Level 1
Greeshma_Sampath1
Level 1

Likes

0 likes

Total Posts

43 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
Greeshma_Sampath1
Level 1

Likes

0 likes

Total Posts

43 posts

Correct reply

0 solutions
Top badges earned
Give Back
View profile
Greeshma_Sampath1
Level 1

14-06-2021

Hi Team,

 

Two workflows was ran 2 days back. When checked today the deliveries status in dashboard and in All deliveries is finished but the delivery activity is still blinking when we opened the workflow and checked. Thus the workflow is still in started state even though the delivery has finished executing. The deliveries are sent and completed.

 

Thanks.

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Boost 5
Employee
kishorep
Employee

Likes

5 likes

Total Posts

8 posts

Correct reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 3
Affirm 1
View profile

Avatar
Boost 5
Employee
kishorep
Employee

Likes

5 likes

Total Posts

8 posts

Correct reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Affirm 3
Affirm 1
View profile
kishorep
Employee

16-06-2021

Hello there,
Believe, you paused on the delivery activity. Later resumed the workflow.
Please DO NOT PAUSE on delivery activity. 
Hope this helps!

Avatar

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,096 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,096 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile
wodnicki
MVP

14-06-2021

Hi,

 

Deliveries are pending or sent and completed?

Is the mta process running (Home > Monitoring tab)?

 

Thanks,

-Jon

Greeshma_Sampath1

Hi @wodnicki ,

 

The delivery is finished as per in dashboard and All deliveries folder. But the workflow was in started state.

The mta process is not used in our services and we never started mta process in our services
 
Thanks
wALF

Hi Greeshma,

What Jon meant was, are all the recipients of the delivery in the Sent state or some of them in the Pending state?  Secondly, the mta is required so please confirm if the mta service running?

We see the same issue but for our triggered emails (Message Center) where the recipients appear in Sent or Ignored state on RT but Pending on the marketing instance.

 

-Harshal

Greeshma_Sampath1

Hi @wALF ,

All the recipients are in sent state. In our testing we found that the delivery was in "enable but do not execute" state while the wf was ran and when the delivery had extraction file approval also. So the client used to run the wf by keeping this delivery in "enable but do not execute" state and run till the previous activity of delivery, to see the count and then they remove the pause of the delivery. After this the wf goes to pause state as the delivery is in "enable but do not execute" so they start the wf again. This is what they have been doing and thus the delivery activity was still blinking and the wf was in started state till we manually stop the wf.

Could you please tell me like because of what this happened?

We tried to replicate without the approval in delivery but then the delivery got finished. So we think its because the delivery was paused and had approval. Could you please give an idea on what is the root cause for this?

 

Thanks.