WebService Parameters prefixed by Type e.g. "str"

Tim_Goodman_BTE

07-07-2019

Hi,

We have a server - when we define a webservice, every parameter name in the WSDL is prefixed by the type e.g. "str", "dom" etc

This looks like it is a server config, but we can't find where (nothing obvious in options)

See the below image for an example - two WSDLs created from the same schema on two separate servers

  • The top shows as expected - parameter names are as they are defined in the schema
  • The bottom shows the parameter names being prefixed automatically

Is there a configuration we can set to remove the prefixes?

SOAP_vartypes.PNG

Schema definition (snippet) here

  <methods>

    <method library="xxx:leadEvent.js" name="LeadEvent" static="true">

      <help>Insert an XXX Lead event.</help>

      <parameters>

        <param desc="Source System" inout="in" label="sourceSystem" name="sourceSystem"

               type="string"/>

        <param desc="Form ID" inout="in" label="formID" name="formID" type="string"/>

        <param desc="Event Type" inout="in" label="eventType" name="eventType" type="string"/>

        <param desc="Event TimeStamp" inout="in" label="eventTimeStamp" name="eventTimeStamp"

               type="string"/>

        <param desc="Source System Record ID" inout="in" label="sourceSystemRecordID"

               name="sourceSystemRecordID" type="string"/>

        <param desc="Form Payload" inout="in" label="formPayload" name="formPayload"

               type="DOMDocument"/>

Accepted Solutions (1)

Accepted Solutions (1)

Tim_Goodman_BTE

08-07-2019

Issue seems to have fixed itself after an upgrade to build 9026

Interestingly, the server accepts SOAP requests using either notation e.g.

          <urn:sourceSystem>sourceSystem</urn:sourceSystem>

OR


          <urn:strSourceSystem>source-aSystem</urn:strSourceSystem>

Just don't use both in the same call!

Answers (0)