Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

web.log stopped updating

ckelsey79
Level 1
Level 1

My web.log logs stopped updating after September 2019. I can see logs from August of 2019 to September 2019 and then there is nothing after that. Does anyone know what could've caused this and how to fix it?

 

Thanks in advance!

1 Accepted Solution
Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi,

 

Based on your description there are three possibilities:

 

1. Your log location is different from the default log location for Adobe campaign

2. you are not using syslogd for logs. By default, the Adobe Campaign platform has the syslogd module installed on it, but it is possible to use another syslog daemon. This module creates the log files in the log directory. If you had any build or infra updates this might have happened.

3. Somehow your web.log creation is disabled.

 

Follow this step to ensure that you are actually generating logs in the default location: 

use a file/Js activity in workflow and test if you have a web.log file in the given directory

<installation directory> /var/default/log/ 

 

if you do not have this file raise a Support ticket and they will be able to fix it for you.

If on-premise then reach out to your support admin.

 

regards,

Amit

View solution in original post

5 Replies
Amit_Kumar
Correct answer by
Community Advisor
Community Advisor

Hi,

 

Based on your description there are three possibilities:

 

1. Your log location is different from the default log location for Adobe campaign

2. you are not using syslogd for logs. By default, the Adobe Campaign platform has the syslogd module installed on it, but it is possible to use another syslog daemon. This module creates the log files in the log directory. If you had any build or infra updates this might have happened.

3. Somehow your web.log creation is disabled.

 

Follow this step to ensure that you are actually generating logs in the default location: 

use a file/Js activity in workflow and test if you have a web.log file in the given directory

<installation directory> /var/default/log/ 

 

if you do not have this file raise a Support ticket and they will be able to fix it for you.

If on-premise then reach out to your support admin.

 

regards,

Amit

View solution in original post

ckelsey79
Level 1
Level 1

Hi Amit,

 

I ran the script and the application is pointing to the right location and the log exists, but it's still not updating.

 

Thanks,

Chris

Amit_Kumar
Community Advisor
Community Advisor
Can you share details from web > jsp > classpath node for all class paths? I think if you are not seeing any logs may be log4j is missing.
ckelsey79
Level 1
Level 1

Hi Amit,

 

I'm not seeing path on my servers or in my instances, including my test environment where the logs are working. Can you clarify where that is located?

 

Thanks,

Chris