Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Updating default in factory schema

Avatar

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile
Partha18
Level 3

01-10-2019

Hi team,

we have a requirement that we want to change the default value of an attribute in a factory schema.

Say, for example, in xtk:workflow schema,

    <attribute default="3600" label="Delay" name="delay" type="timespan"/>

I Need to change this default value to 3000.

So what can i do? I have extended xtk:wokflow schema as  abc:workflow. Now what should i need to?

Please help me with this!

Thanks and Regards,

Partha.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile
Partha18
Level 3

01-10-2019

Hi David ,   davidk23955130

Thanks for responding!

So u will place this syntax in extended schema?

As per my case, mentioned in my question, i need to extend xtk:workflow and save it as abc:workflow,

And then i need to insert this

<attribute default="'3000'" label="Delay" name="delay" type="timespan" sqlDefault="'3000'"/>

Am i right? or we need to use any attributes like update to update this default value?

(in xtk:workflow it will be default="3600", but i need to change that default into 3000)

Thanks and Regards,

Partha

Answers (5)

Answers (5)

Avatar

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
DavidKangni
MVP

07-10-2019

Hi Partha,

you're trying to set up a default value to 20 while your workflows templates are set up to 30.

1840731_pastedImage_0.png

Thanks

David

Avatar

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
DavidKangni
MVP

01-10-2019

Hi Partha,

Here is an example of syntax to achieve this

   <attribute default="'0'" label="PrimaryPhoneNumber" length="30" name="primaryPhoneNumber" notNull="true" sqlDefault="'0'"

type="string"/>

thanks

david

Avatar

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile
Partha18
Level 3

07-10-2019

Hi davidk23955130​ ,

Thank you so much!

Avatar

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile

Avatar
Validate 10
Level 3
Partha18
Level 3

Likes

19 likes

Total Posts

29 posts

Correct Reply

2 solutions
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 10
View profile
Partha18
Level 3

07-10-2019

Hi, davidk23955130

I want my "history" attributes default value as "20" in xtk:workflow. so i extended that schema, and gave the attribute as you mentioned above.

1841399_pastedImage_0.png

(Note: while i tried to update database structure, i didn't found anything to update there.)

Then i disconnected and reconnected.

Then i created a dummy workflow and i found the history of that newly created workflow as "30" and not "20" in xtk:workflow data.

So This doesn't worked for this case. Please help me with this!

Thanks and Regards,

Partha.

Avatar

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Validate 1
MVP
DavidKangni
MVP

Likes

248 likes

Total Posts

359 posts

Correct Reply

142 solutions
Top badges earned
Validate 1
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
DavidKangni
MVP

01-10-2019

correct. It will work for the new entries created. old entries need to be updated if needed