Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Split activity is not working

kumarg
Level 2
Level 2

Hi,

 

I am trying to split the records based on the channel type but after split activity i am not getting all the channel type records. I am getting two email records only rest of the 4 records are Mobile type not getting.

 

Here is my workflow

kumarg_0-1602192873855.png

 

 

Thanks in advance.

 

1 Accepted Solution
kumarg
Correct answer by
Level 2
Level 2
I just check the "Enable overlapping of output population" in General tab now it's giving both the records...

View solution in original post

7 Replies
ParthaSarathy
Level 5
Level 5

Hi @kumarg ,

In Workflow property, Select 'Keep the results of interim result'

In split activity > General tab > select 'Generate complement' and run the workflow again.

Now click on the complement transition arrow, right click and select display the target. You can see the remaining data. Configure the list and add channel. Now you can troubleshot why those records didn't came in your SMS transition.

 

Regards,

ParthaSarathy S.

 

kumarg
Level 2
Level 2
Even compliment transition arrow getting zero records.. I have changed the first split condition channel type as Mobile second split condition channel type as Email then i am getting SMS records only not for Email.. Only the first condition records are getting not for other conditions in split activity...
kumarg
Level 2
Level 2

Please find below screen short for Subset and General tab.

kumarg_0-1602249842325.png

 

kumarg_1-1602249875073.png

 

kumarg_2-1602249906783.png

 

ParthaSarathy
Level 5
Level 5
Seems configurations are correct in split activity. But once Try using 'Additional data only' in General tab and run the WKF and post the screenshot of workflow o
kumarg
Correct answer by
Level 2
Level 2
I just check the "Enable overlapping of output population" in General tab now it's giving both the records...

View solution in original post

SachinDhir
Level 2
Level 2

Check the targeting, there must be duplicates on targeting dimension.