Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Schema config in ACC

Avatar

Level 3

 

Hello All,

pLEASE TELL ME ABOUT THIS: We have transaction table in our database, and transaction schema in adobe campaign,,we have one field named Transaction ship date present in DB but the same field is not present in Transsssactions schema present in ADOBE Campaign..is this possible or okay that some fields are present in db in same table but same field not present in transactions schema in ACC

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi @Shruti1 ,

 

Been here and done that haha. It is a bit of a bugger situation to be in. 

I am assuming here but I  think the issue is that the field was created in the backend DB and not pushed across via adobe campaign update database wizard so here are the steps.

 

Tell your db team to delete the field from the back end and bounce the environment

Then you add the field to adobe campaign schema (ensure to update your loaders and everything too)

Then you run the database update wizard (make sure you log out and log back in again otherwise the change will not be seen)

This will resolve the issue

 

If you try and add that field to the schema in adobe campaign without the team updating it on the backend you will be stuck in a loop where adobe campaign will kick and scream about the field already exists, all deployments  of new fields should be done from adobe campaign and deployed via the database update wizard otherwise issues will arise.

 

Hope this helps 🙂 

View solution in original post

0 Replies

Avatar

Employee Advisor

Hi Shrutil,

 

It really depends on whether or not you need the fields. If you are exporting/importing data from one database to the other, then as long as you are not trying to insert those missing fields or reference them as an identifier then it should not be an issue.

 

Regards,

Craig

Avatar

Correct answer by
Level 2

Hi @Shruti1 ,

 

Been here and done that haha. It is a bit of a bugger situation to be in. 

I am assuming here but I  think the issue is that the field was created in the backend DB and not pushed across via adobe campaign update database wizard so here are the steps.

 

Tell your db team to delete the field from the back end and bounce the environment

Then you add the field to adobe campaign schema (ensure to update your loaders and everything too)

Then you run the database update wizard (make sure you log out and log back in again otherwise the change will not be seen)

This will resolve the issue

 

If you try and add that field to the schema in adobe campaign without the team updating it on the backend you will be stuck in a loop where adobe campaign will kick and scream about the field already exists, all deployments  of new fields should be done from adobe campaign and deployed via the database update wizard otherwise issues will arise.

 

Hope this helps 🙂 

Avatar

Administrator

Hi @Shruti1,

Were you able to resolve this query with the help of the given solutions or do you still need more help here? Do let us know.
Thanks!