Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Scheduled workflow getting executed before the assigned schedule time

Greeshma_Sampath1
Level 3
Level 3

Hi Team,

 

Iam having an issue with a scheduled workflow.

The problem is the workflow got executed 10 mints before the assigned time.

The workflow executes every 30 mints, but today the wf got executed 10 mints before.

The workflow,

Greeshma_Sampath1_1-1617862931721.png

 

The logs are mentioned below for understanding.

Greeshma_Sampath1_0-1617862869212.png

 

Could someone kindly tell me what can be the problem?

 

Thanks,

Greeshma.

 

1 Accepted Solution
craigthonis
Correct answer by
Employee
Employee

Hello Greeshma,

 

If you completely stop the workflow, save it, and then restart it does the issue persist? If a workflow was running, then was paused, altered, and resumed, the previous underlying workflow job doesn't get changed and will still execute with the previous configuration. Performing a full restart clears the underlying job and refreshes it with the new execution criteria.

 

Just from what I'm seeing here, it's the only scenario that I can think of that would cause your workflow to kick off prior to the scheduled time.

 

Regards,

Craig

View solution in original post

4 Replies
craigthonis
Correct answer by
Employee
Employee

Hello Greeshma,

 

If you completely stop the workflow, save it, and then restart it does the issue persist? If a workflow was running, then was paused, altered, and resumed, the previous underlying workflow job doesn't get changed and will still execute with the previous configuration. Performing a full restart clears the underlying job and refreshes it with the new execution criteria.

 

Just from what I'm seeing here, it's the only scenario that I can think of that would cause your workflow to kick off prior to the scheduled time.

 

Regards,

Craig

View solution in original post

Greeshma_Sampath1
Level 3
Level 3

Hi Craig,

 

Thank you for your response. 
But the workflow was not being edited or paused or done any changes.
This workflow was running for past so many days continuously and it didn't have this issue.

Darren_Bowers
Community Advisor
Community Advisor

Hi @Greeshma_Sampath1 - There are a couple of strange time entries in there. The first one is when the workflow ran at 02:31:51 PM - that's almost a 2 minute schedule delay. It could indicate your system is under large performance load.The 20 minute delay at 03:50:12 PM is pretty extreme though.

The late starts could also be related to other factors like @craigthonis mentioned or if a workflow killed the Campaign Jobs (operationMgt) workflow and required a restart.

Cheers

Darren