Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Personalized auto filled form

Avatar

Level 4

How can I create a web application which has a form and gets auto-filled with user details once the user clicks the hyperlink of that web application in an email? My scenario is: When a user clicks the hyperlink in an email it takes the user to the form page and the form gets auto-filled with user details. The user can just click submit and the lead record will be sent.

TIA

1 Accepted Solution

Avatar

Correct answer by
Level 2

Hi ihm185

Using "?"  for parameters offcourse works only if it is the first parameter, all other parameters thereafter should be preceded by "&". so in your example you should use &id=<%=escapeUrl(recipient.cryptedId)%>

View solution in original post

9 Replies

Avatar

Employee Advisor

Hi Tia,

Not sure if your request is for ACC or ACS.

In ACC you can have the pre-loading object on the Webapp canvas which will prepopulate the details based on the link you will provide inside the email link.

Please refer to the documentation<https://docs.campaign.adobe.com/doc/AC/en/WEB_Web_applications_About_web_applications.html> for more information

Regards,

Vipul

Avatar

Level 4

Thank you Vipul for replying,

I am using ACC. I have selected a preloader activity and have mapped my fields from the table. How can i link email hyperlink to prefill data of the same person who is receiving the delivery? Kindly, let me know the process.

thanks in advance

Avatar

Level 10

Hi Imran,

Please post on the Adobe Campaign Classic forums next time Moving this post there for follow up!

Thanks!

Avatar

Level 4

Thank you Pablo, for moving my question to the relevant forum. I 'd really appreciate if you can help me with my query.

regards,

Imran

Avatar

Level 2

Hi there,

Just add

     ?id=<%=escapeUrl(recipient.cryptedId)%>

in the link to your landingpage (webapp) in your email.

Adobe Campaign automatically recognizes the id parameter fur use with the pre-loading activity.

Just be sure to set the Identificationmethod for the preload Activity to "Adobe Campaign encryption" (or "Automatic" ).

Kind Regards,

-Menno

Avatar

Level 4

Thank you for replying.

I tried suffixing ?id=<%=escapeUrl(recipient.cryptedId)%> to my webapp link this

m.comms.ourdomain.com/webApp/APP1771?id=<%=escapeUrl(recipient.cryptedId)%>

But its not working.

Please check the image.

Capture.JPG

Avatar

Level 2

I think the ID is not correct.

You can debug the error, by checking "Enable debug mode" in the "preview" tab of the webApp.

1628167_pastedImage_0.png

then add the &id=  to the url on the preview tab and go.

1628306_pastedImage_5.png

You will probably get something like this:

1628303_pastedImage_1.png

Followed by some XML data of the variables and activities processed so far in the wabapp

If this is the case: the encrypted identifier is incorrect (not the correct format) You can find the crypted Id as part of the recipient schema.  Or encrypt on the fly by using id=<%= escapeUrl(cryptString(recipient.id)) %>

As displayd on the "dashboard" tab of the wabapp:

1628304_pastedImage_2.png

Which is added to the dashboard after you placed the "Preloading" activity on the flow-sheet of the wabapp.

Avatar

Level 4

Thank you  Menno for the reply,

After suffixing the ID to the URL, I am neither getting any error nor getting the correct result.

This is my form

debug.JPG

This is the workflow

wkflw.JPG

This is the preloading

auto_fill.JPG

Am I doing anything incorrect?

Avatar

Correct answer by
Level 2

Hi ihm185

Using "?"  for parameters offcourse works only if it is the first parameter, all other parameters thereafter should be preceded by "&". so in your example you should use &id=<%=escapeUrl(recipient.cryptedId)%>