Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

ORA-01652:unable to extend temp segment by 128 in tablespace TEMP

Avatar

Avatar
Validate 1
Level 1
Ofattah
Level 1

Likes

0 likes

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
Ofattah
Level 1

Likes

0 likes

Total Posts

5 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
Ofattah
Level 1

02-06-2021

Hello everyone,
I hope you can help me solve this issue.
We launched a workflow with a query-->enrichment box-->change dimension box...
The workflow stops just when it reaches the change dimension box because of the following error: ORA-01652:unable to extend temp segment by 128 in tablespace TEMP.

We already extended the temp tablespace in the database, but it didn't resolve the problem.
Do you have an idea please? because we had the same error with the same workflow in the query box too before.Tablespace.PNG 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 1
Level 1
venkatesanj1458
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

1 solution
Top badges earned
Affirm 1
Establish
Give Back
Ignite 1
Boost 1
View profile

Avatar
Affirm 1
Level 1
venkatesanj1458
Level 1

Like

1 like

Total Posts

3 posts

Correct Reply

1 solution
Top badges earned
Affirm 1
Establish
Give Back
Ignite 1
Boost 1
View profile
venkatesanj1458
Level 1

02-06-2021

Hi @Ofattah 

This could be because the resulting data set fetched by the query is exceeding the temp tablespace in oracle DB. Please have a DBA involved and extend the temp tablespace in the database.

 

Answers (1)

Answers (1)

Avatar

Avatar
Boost 10
Level 2
LaurentLam
Level 2

Likes

11 likes

Total Posts

34 posts

Correct Reply

4 solutions
Top badges earned
Boost 10
Contributor
Applaud 5
Affirm 3
Affirm 1
View profile

Avatar
Boost 10
Level 2
LaurentLam
Level 2

Likes

11 likes

Total Posts

34 posts

Correct Reply

4 solutions
Top badges earned
Boost 10
Contributor
Applaud 5
Affirm 3
Affirm 1
View profile
LaurentLam
Level 2

02-06-2021

Hi @Ofattah 
Does the neolane DB user has the right to extend the temp segment:

I'm not DBA at all but it seems that, due to the request, the user is trying to do it by itself, and that's the result

if not possible, I would then try to

1- try to reproduce the issue with the less sample data as possible in order to know if this is a structural issue in the generated SQL queries or not

2- if this is a structural issue then simplify the enrichment and trying to reproduce the problem by adding more and more links/fields in order to understand which field or link create the issue

Ofattah

Hi @LaurentLam 

Thank you for your response,

I just tried to reduce the fields of the enrichment box (from around 10 to only 2) and it went well. The problem is that we use the same workflow with another account and it works just fine.

Thanks

LaurentLam

Hi @Ofattah, when you say that you use the workflow with another account and it works just fine. Do you mean that this is another AC user that running it? if yes, be sure to check the difference between your rights. As example, a SQL query gets more complicated if not administrator because it adds lot of security checkings in the SQL request generated to the DB. As a personnal opinion, I would try to put a split activity in order to split in 10 different branch the rest of your workflow: you'll be able to see that:

1- if the problem disappear => that means that this is an issue with the total amount of data and its complexity that is involved

2- if the issue pops on one branch but not the other before, you can nail the issue to a particular data in that segmentation: you can just then select the same population of this branch and segment it again in 10 part. with this method, you'll find at the end which record(s) is/are causing the issue

 

I've not any better suggestion: I know that this is time consuming

Ofattah

Hi @LaurentLam 

Thank you for your response,

I meant that I use two accounts (each account has a predefined "country" filter to only target one specific country according to the account I'm using). 

For country A the workflow works fine but for country B it doesn't.

I will try your suggestion to see if I can have an idea about what's causing this problem.

Thank you.