Link redirections failing

Avatar

Avatar

rohanpat

Avatar

rohanpat

rohanpat

07-06-2020

Hi,

Wanted to know where and what configuration needs to be added for links used in delivery content to use a standard, say adobe domain?

 

Like I am integrating adobe with my system server, have done the configurations accordingly, wherein it does call my MTA, but upon delivery, what-ever links I had, say www.google.com gets encrypted into a said format with my server name as domain. So redirection fails. To avoid this, I feel, somwhere in configuration need to add adobe domain, so that my links get redirected and tracked as well.

 

Could someone please help here....

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

_Manoj_Kumar

MVP

Avatar

_Manoj_Kumar

MVP

_Manoj_Kumar
MVP

08-06-2020

Hello @rohanpat,

 

You will have to add a tracking server to your instance. Once the tracking server is added then you can enable the tracking in emails.

 

Here is the documentation on tracking server: https://helpx.adobe.com/campaign/kb/acc-tracking.html

https://docs.adobe.com/content/help/en/campaign-classic/using/installing-campaign-classic/initial-co...

 

To test if the tracking server is setup you can use this URL:

 

https://YOUR_INSTANCE_URL/r/test

 

 

Once the tracking is enabled only then you will be able to track the clicks/opens coming from your emails.

 

To Change domain from MTA to your own domain You will have to set up the domain delegation:

Here is the documentation:

https://helpx.adobe.com/campaign/kb/domain-name-delegation.html

Hi @manoj, Actually, I am planning to use adobe.com domain, so that its tracked by default by adobe system. Now the issue what I am facing is, since I am using my own MTA server for deliveries, the url links upon delivery get encrypted as expected but instead of using adobe domain, its picking up my mta server name which leads to invalid domain issue causing links not to re-direct. So am looking for a solution, where-in I can use adobe domain and nothing to be done at my end when it comes to link tracking. Believe some-where in configuration, I need to specify what domain the links should use?
Updated the answer to set up the domain delegation

Thank you very much @manoj. It was quite helpful, I now got to know from where the links were picking my the domain. Thanks for sharing the links, especially the one with resp to deployment wizard. Following those steps should fix my issue. One more question I had, since email deliveries are happening via my MTA server, and I need to sync the stats with adobe reporting, what table do I need to refer for insertion so that the stats start showing up in UI? Any specific one under broadlog?

Yes, for the delivery logs you want to update the Recipient delivery logs and for click and open the table is Recipient Tracking logs
Thanks again @manoj, will try out and get back to you in case of any further queries.

Hi @manoj, I manually inserted few values in Recipient delivery log table, but it stats didn't show up on reports. Am I missing here anything?

You will have to associate the records with the deliveries
Hi @manoj, still no luck. Couldn't find a way to attach the snap here so that you will get a fair bit of idea where I am looking. But here's the flow in campaign classic where I am looking for the stats : "open delivered mail->select summary tab->delivery option(Right top)->Non-deliverables and bounces". Could you confirm what table I need to refer, so that I could see stats or its the same one?

Report.png

 

Hi @manoj, here's the attachment for your reference.

Answers (0)