Input Forms issue

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

23-08-2019

Hi All,

I have created an Input form and while double-clicking on the form to change the details of any record it is ending up by closing the campaign console.

It's not allowing me to double click and rather disconnecting me from my console. Can someone help me in this case?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

28-08-2019

This issue was resolved by adding the <view form="<SchemaName>" in the Navigation Hierarchy and by enclosing all containers with a root container.

<container>

...

...

</container>

Thanks, Saikat for your time and help.

Answers (7)

Answers (7)

Avatar

Avatar
Contributor
MVP
Anita_p
MVP

Likes

119 likes

Total Posts

119 posts

Correct reply

29 solutions
Top badges earned
Contributor
Shape 1
Ignite 3
Ignite 1
Validate 1
View profile

Avatar
Contributor
MVP
Anita_p
MVP

Likes

119 likes

Total Posts

119 posts

Correct reply

29 solutions
Top badges earned
Contributor
Shape 1
Ignite 3
Ignite 1
Validate 1
View profile
Anita_p
MVP

26-08-2019

Hi Bittu,

Can you please check if that is the case with other forms as well or only with the one you created ?

Thanks,

Anita

Avatar

Avatar
Establish
Employee
Adhiyan
Employee

Likes

241 likes

Total Posts

343 posts

Correct reply

124 solutions
Top badges earned
Establish
Give Back 50
Give Back 25
Give Back 10
Give Back 5
View profile

Avatar
Establish
Employee
Adhiyan
Employee

Likes

241 likes

Total Posts

343 posts

Correct reply

124 solutions
Top badges earned
Establish
Give Back 50
Give Back 25
Give Back 10
Give Back 5
View profile
Adhiyan
Employee

27-08-2019

Hi Bittu,

I guess you need to add the two attributes to the form to make it work.

editionMode="dialog" entity-schema="<namespace>:<schema>"

So your parent form element should have

<form .......

editionMode="dialog" entity-schema="<namespace>:<schema>"

.....

      xtkschema="xtk:form">

I believe , it's not able to fetch the schema which the form is connected to and hence ends up crashing the console

Regards,

Adhiyan

Avatar

Avatar
Contributor
Level 3
saikatk2447661
Level 3

Likes

22 likes

Total Posts

58 posts

Correct reply

14 solutions
Top badges earned
Contributor
Shape 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Contributor
Level 3
saikatk2447661
Level 3

Likes

22 likes

Total Posts

58 posts

Correct reply

14 solutions
Top badges earned
Contributor
Shape 1
Give Back 5
Give Back 3
Give Back
View profile
saikatk2447661
Level 3

26-08-2019

Hi Bittu,

Can you paste the input form XML here?

Thanks,
Saikat

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

27-08-2019

I tried Still its not working.The console is Crashing

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

27-08-2019

Hi Saikat,

Here is the xml

<form _created="2019-08-26 08:19:11.944Z" _createdBy-id="3144567" _cs="Dealxyz (abc)"

      _lastModified="2019-08-27 13:32:13.327Z" _modifiedBy-id="31466422" created="2019-08-26 06:35:37.706Z"

      createdBy-id="3144567" entitySchema="xtk:form" img="xtk:form.png" label="Dealxyz"

      lastModified="2019-08-20 02:33:06.359Z" md5="2XY2C8E3D0F511E82014442C1C809"

      modifiedBy-id="93875176" name="Dealxyz" namespace="abc" type="notebook"

      xtkschema="xtk:form">

  <createdBy _cs="mmmmmmmmmmmmmmmmm"/>

  <container label="Details" name="Details">

    <input readOnly="true" xpath="@id"/>

    <input readOnly="true" xpath="@Name"/>

    <input readOnly="true" xpath="@bookStatus"/>

    <input xpath="@isActive"/>

  </container>

  <container label="Some Dates" name="someDates">

    <input xpath="@someydate"/>

    <input xpath="@somexdate"/>

    <input xpath="@somexTime"/>

    <input xpath="@somezStartTime"/>

  </container>

  <container label="Price Details" name="PriceDetails">

    <input xpath="@minPrice"/>

    <input xpath="@maxPrice"/>

    <input xpath="@finalPrice"/>

  </container>

  <container label="Other Details" name="OtherDetails">

    <input xpath="@somethingx"/>

    <input xpath="@somethingxy"/>

    <input xpath="@somethingxyz"/>

    <input xpath="@somethingxxyza"/>

    <input xpath="@somethingxxyzab"/>

  </container>

</form>

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

27-08-2019

This issue is only for the forms i created.

Avatar

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 2
bittu4551
Level 2

Likes

4 likes

Total Posts

7 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 1
View profile
bittu4551
Level 2

27-08-2019

This issue is only with the forms I created.

On Tue, Aug 27, 2019 at 2:18 AM anitap82640902 <forums_noreply@adobe.com>