How to display targeting and workflow tab by default while creating campaign template

Avatar

Avatar
Boost 5
Level 2
ramprakasht3196
Level 2

Likes

9 likes

Total Posts

44 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Boost 5
Level 2
ramprakasht3196
Level 2

Likes

9 likes

Total Posts

44 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
ramprakasht3196
Level 2

05-01-2021

Hi,

 

While creating campaign template Targeting and Workflow tab is not displayed by default.

ramprakasht3196_0-1609858212741.png

Targeting and workflows tab should be enabled in the Advanced campaign parameter option as given below.

ramprakasht3196_1-1609858681127.png

 

Could you please guide me, how to set "Targeting and workflows" value  "Yes" by default.

 

Thank You! 

 

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Boost 250
MVP
DavidKangni
MVP

Likes

260 likes

Total Posts

372 posts

Correct reply

152 solutions
Top badges earned
Boost 250
Validate 1
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Boost 250
MVP
DavidKangni
MVP

Likes

260 likes

Total Posts

372 posts

Correct reply

152 solutions
Top badges earned
Boost 250
Validate 1
Give Back 5
Give Back 3
Give Back 25
View profile
DavidKangni
MVP

05-01-2021

Hi @ramprakasht3196 ,

 

You will need to extend your operation schema and set the useWorkflow as true per default

<attribute default="true" label="Targeting and workflows" name="useWorkflow" type="boolean"/>

 Thanks,

David

Avatar

Avatar
Boost 5
Level 2
ramprakasht3196
Level 2

Likes

9 likes

Total Posts

44 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Boost 5
Level 2
ramprakasht3196
Level 2

Likes

9 likes

Total Posts

44 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
ramprakasht3196
Level 2

07-01-2021

Hi @DavidKangni ,


I have tried the code in schema. The attribute useWorkflow is defined with xml="true" in the schema(nms:operation). So I was unable to achieve the solution. Is there any other solutions for this.

 

BR,

Ram.