Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Error on split activity level with a table Account

thibaultb473199
Level 4
Level 4

Hello everyone,

I have a recurring problem on the account table "Account"
This happens especially when I load the delivery logs of the "Account" table, that I enrich and change dimension to the "Account "table. So far everything is fine but when I want to make a split using a variable of the "Account" table, I have this error message: Attribute AccountsKey1 unknow

You can see the logs of the workflow here :

Rg3AAgj9Tb.png

This is what the workflow looks like and the issue coming from the slit activity :

nlclient_AE6eb2rFu7.png

What can I do a resolve this issue ? If you need more information, feel free to ask me.

Thank you in advance.

Kind regards.

1 Accepted Solution
thibaultb473199
Correct answer by
Level 4
Level 4

Hello,

I find the solution, this one was coming from the first enrichment that didn't have the data specified inside. Adding this one makes the workflow runs correctly.

Kind regards

View solution in original post

3 Replies
taplondon_rohan
Level 1
Level 1

Hi @thibaultb473199 ,

 

Would you be able to check the targeting dimension on your split activity ? Looking at the error message, it looks like the targeting dimension of your split activity and the temporary workflow table are both different (nms:recipient and thi:accounts) so the split is unable to process the AccountsKey1  attribute.  

 

rohan_taplondon_0-1599580272652.png

 

 

In your split activity, if you set the targeting dimension to temporary schema and select the "enrichment 3" option, that should give you access to the fields from the temp workflow table. 

 

Thanks,

Rohan

 

 

Sukrity_Wadhwa
Employee
Employee

Hi @thibaultb473199,

Were you able to resolve this query with the given solution? Please let us know.

Thanks!

thibaultb473199
Correct answer by
Level 4
Level 4

Hello,

I find the solution, this one was coming from the first enrichment that didn't have the data specified inside. Adding this one makes the workflow runs correctly.

Kind regards

View solution in original post