Does Adobe Campaign server support PHP

Avatar

Avatar
Validate 1
Level 1
Roxie423
Level 1

Likes

2 likes

Total Posts

30 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
Roxie423
Level 1

Likes

2 likes

Total Posts

30 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
Roxie423
Level 1

08-11-2020

Hello,

 

Does Adobe Campaign server support PHP? 

If so, where should one upload the PHP files to?

 

Thanks in advance.

 

Cheers,

Roxie

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
MVP
Darren_Bowers
MVP

Likes

90 likes

Total Posts

286 posts

Correct reply

87 solutions
Top badges earned
Validate 1
Affirm 50
Establish
Give Back 3
Applaud 25
View profile

Avatar
Validate 1
MVP
Darren_Bowers
MVP

Likes

90 likes

Total Posts

286 posts

Correct reply

87 solutions
Top badges earned
Validate 1
Affirm 50
Establish
Give Back 3
Applaud 25
View profile
Darren_Bowers
MVP

08-11-2020

Hi Roxie - Campaign Classic does not natively support PHP. It uses JSSP for its server-generated pages https://blog.floriancourgey.com/2018/11/create-jssp-dynamic-javascript-server-page-in-acc/

There are some PHP wrappers for Experience Cloud APIs that people have built. The other option is to build your own wrapper for PHP using SOAP to implement the native APIs

Cheers

Darren

Answers (1)

Answers (1)

Avatar

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,097 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile

Avatar
Establish
MVP
wodnicki
MVP

Likes

977 likes

Total Posts

1,097 posts

Correct reply

516 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile
wodnicki
MVP

09-11-2020

Hi,

 

Adobe Campaign doesn't, but part of installation is to front it with Apache or IIS for connection handling.

Install PHP modules to whichever's in use and you'll be fine.

If you want to make use of Adobe Campaign java bindings you'll have to use JSP.

 

Thanks,

-Jon