Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Display different UnSubscription page

akramullak35861
Level 3
Level 3

We have a business requirement based on the Business Unit, we need to display different UnSubscription page. But when I preview I get the same UnSubscription page, irrespective of Business Unit I select of the Recipient.

1839444_pastedImage_0.png

1 Accepted Solution
Jean-Serge_Biro
Correct answer by
Community Advisor
Community Advisor

Hi Akramullak,

On which branch do you arrive systematically ?

Please may you add a Javascript activity after the Preloading activity, and writes down a logInfo("[Unsubscribe webApp] Business Unit" + recipient.@BU);

then check web.log for result (on MTA / web server, not applicative server).

Or more convenient, use the debug mode in preview window pane, with a specific test user account, so you can see the context (ctx) content and understand better.

Regards
J-Serge

View solution in original post

5 Replies
Jean-Serge_Biro
Community Advisor
Community Advisor

Hi Akramullak,

If the Test activity is done on an element/attribute not beeing present in your forms (even if it is an hidden html field), hence it is not automatically preloaded, so you must preload it in the Preload activity by adding it in the Additional Data Preload section.

Regards
J-Serge

akramullak35861
Level 3
Level 3

Hi J-Serge,

I had already added BU to Preloading, checking for it in Test and exposed it in Page activity.

1839448_pastedImage_0.png

1839761_pastedImage_1.png

Jean-Serge_Biro
Correct answer by
Community Advisor
Community Advisor

Hi Akramullak,

On which branch do you arrive systematically ?

Please may you add a Javascript activity after the Preloading activity, and writes down a logInfo("[Unsubscribe webApp] Business Unit" + recipient.@BU);

then check web.log for result (on MTA / web server, not applicative server).

Or more convenient, use the debug mode in preview window pane, with a specific test user account, so you can see the context (ctx) content and understand better.

Regards
J-Serge

View solution in original post

akramullak35861
Level 3
Level 3

Hi J-Serge,

logs are showing correct BU

1839864_pastedImage_0.png

Default its going to Mkt_Unsubscription

<ctx lang="en-US" activityHist="@5jveBpxiuDuoW3eGuQ1f7vBZ0QbUmjIN/OsbeJbd/nLFELNRnbFThXZYv9WRXDdcKGRcocOxyVpU0WLcOSFD+XB6fbpeVd5PLp8LjiUx2/6YLX4N3ZaQgQJNWWhIor+mYpRaZKvzvEXd+bb9QDfEhUNrt72NBJ1UyeKKnXJyianxgmouNAuSRbW+NxBa/bm9XmYAXiY7W2hXjSurNwML82503HChxGBnh+ejrRdjzbR9wSvykrm4Vp8acSL/wTfZQplfZNiVtjorpaRj4LLyLZGbd9Ms+v+EeTifdvh1Aqs=" secret="@A7sqztQnN2zSIKFCg8uAoPaL3+pNOxI8JWEC1aGqvUv06WZEWneiz9B7H7LSnTZ7UNisuK/uHXZBsYPkldPks94kPNHdR0GyXJhVkGLj3dvi/ZcYrSIuadatfCcYSMZEMpbHZ/UL7u1vH0sS7REoyPNiiiqclwYT/7LitXajVmg=" _method="encryptedId" _identifier="@Zy7H+xFsuTINQct23Ry0Ow==" _folderModel="nmsRecipient" origin="neolane" webApp-id="2650124" _target="web" date="2019-10-03T17:12:21Z" score="0" _console="1">

  <userInfo timezone="America/New_York" theme="" orgUnitId="0" noConsoleCnx="true" loginId="3467" loginCS="Web applications agent (webapp)" login="webapp" locale="en-US" instanceLocale="en-US" homeDir="" datakitInDatabase="true">

    <login-right right="sql" />

    <login-right right="webapp" />

  </userInfo>

  <timezone changed="false" current="America/New_York" />

  <recipient _key="@id" _operation="update" id="2660032" email="ixxx.exxx@yahoo.com" BULabel="OSRM USA" BU="OSRM-US">

    <BU>OSRM-US</BU>

    <BULabel>OSRM USA</BULabel>

  </recipient>

  <activityHistory>

    <activity name="htmlPage" type="htmlPage" />

    <activity name="test" type="test" />

    <activity name="script" type="script" />

    <activity name="prefill" type="prefill" />

  </activityHistory>

</ctx>

<ctx lang="en-US" activityHist="@5jveBpxiuDuoW3eGuQ1f7vBZ0QbUmjIN/OsbeJbd/nLFELNRnbFThXZYv9WRXDdcKGRcocOxyVpU0WLcOSFD+XB6fbpeVd5PLp8LjiUx2/6YLX4N3ZaQgQJNWWhIor+mYpRaZKvzvEXd+bb9QDfEhUNrt72NBJ1UyeKKnXJyianxgmouNAuSRbW+NxBa/bm9XmYAXiY7W2hXjSurNwML82503HChxGBnh+ejrRdjzbR9wSvykrm4Vp8acSL/wTfZqRbIUIr11RLdQtoW7NRklULcfsar+8JGhzeORMgPVAg=" secret="@A7sqztQnN2zSIKFCg8uAoPaL3+pNOxI8JWEC1aGqvUu7MgxjWMXupbzkwKBV4F3br/gAZ33IylbZwkprU3sE1DYzUAptWiTZEt+WRhkA8BHP/CwZ95p+WBS/OaEn8+WnioeFGbg9p0dGBqbiHxaw8GubENU3irFqACfQVdjc8iI=" _method="encryptedId" _identifier="@rNFhn2bIOIidi5hDZOGeFg==" _folderModel="nmsRecipient" origin="neolane" webApp-id="2650124" _target="web" date="2019-10-03T17:14:28Z" score="0" _console="1">

  <userInfo timezone="America/New_York" theme="" orgUnitId="0" noConsoleCnx="true" loginId="3467" loginCS="Web applications agent (webapp)" login="webapp" locale="en-US" instanceLocale="en-US" homeDir="" datakitInDatabase="true">

    <login-right right="sql" />

    <login-right right="webapp" />

  </userInfo>

  <timezone changed="false" current="America/New_York" />

  <recipient _key="@id" _operation="update" id="862820" email="axxx.kxxxx@yahoo.com" BULabel="MKPL-US" BU="MKPL-US">

    <BU>MKPL-US</BU>

    <BULabel>MKPL-US</BULabel>

  </recipient>

  <activityHistory>

    <activity name="htmlPage" type="htmlPage" />

    <activity name="test" type="test" />

    <activity name="script" type="script" />

    <activity name="prefill" type="prefill" />

  </activityHistory>

</ctx>

akramullak35861
Level 3
Level 3

Hi J-Serge,

It worked now.

The issue was in the Test activity I had missed using single quote (') for Values.

Thanks

Akramulla Khan