decryptString function not working in Deliveries

sreev97350841

26-01-2020

Hello,

Ours is a hybrid installation. We are using the decryptString function to decrypt PII data. In the Preview mode the variables are decrypted successfully and the actual data is shown, but when we send out a proof or an email the variables are all empty. For some reason the mid sourcing server is not able to handle these functions. This worked fine when using own mail servers to send emails. Has any one come across this issue? Are there any setting in the mid server that have to be changed?

 

Thanks

Sree

Accepted Solutions (1)

Accepted Solutions (1)

MarcelSzimonisz

MVP

26-01-2020

Hello @sreev97350841 

It could be that the function is deprecated and on one instance is already deprecated and on the other not? 

 

Anyway you should be using decryptPassword() instead. But yet another problem that the function is meant only for use in  soap methods. So there is only one option for you to try and that is hmacStr()

 

https://final-docs.campaign.adobe.com/doc/AC/en/jsapi/f-decryptString.html?hl=decryptstring

https://final-docs.campaign.adobe.com/doc/AC/en/jsapi/f-hmacStr.html

Although it may not solve the issue but you can try..

 

Answers (1)

Answers (1)

wodnicki

MVP

28-01-2020

Hi,

 

Decrypting won't work with ootb midsource since each instance has a unique key and the midsource transfer software doesn't handle it. Easy answer is just tell Adobe to overwrite the midsource instance's xtk:option 'XtkKey' with the one you give them from your prod instance.

 

Thanks,

-Jon