Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Created a new schema and then deleted it - Error message

Avatar

Avatar
Level 1
radhikas2660960
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
radhikas2660960
Level 1

Likes

0 likes

Total Posts

8 posts

Correct Reply

0 solutions
View profile
radhikas2660960
Level 1

01-06-2020

Hi,

I recently created a new schema and deleted it. I recreated this and was still receiving en error so deleted it again.

I am now receiving an error message that is 'unkown schema:' It seems that it has not actually deleted, however we cannot see it in the database structure anymore. Therefore, any further schema changes I am trying to do will not work as this error for that specific schema keeps popping up.

Any ideas on what to do in the situation?

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 50
MVP
Jyoti_Y
MVP

Likes

87 likes

Total Posts

123 posts

Correct Reply

55 solutions
Top badges earned
Boost 50
Shape 1
Boost 5
Give Back 5
Give Back 3
View profile

Avatar
Boost 50
MVP
Jyoti_Y
MVP

Likes

87 likes

Total Posts

123 posts

Correct Reply

55 solutions
Top badges earned
Boost 50
Shape 1
Boost 5
Give Back 5
Give Back 3
View profile
Jyoti_Y
MVP

02-06-2020

Hi Radhika,

 

1) Looking at error screenshot:

Reason for error was: <Element> tag of leads was closed in first line itself. It shouldn't be like that.

Define your schema like below:

<element name="lead" id="lead">

<attribute ....>

</element>

 

2) Try to drop table using SQL activity:

DROP TABLE <namespace>Leads

 

3) Once done, clear your local cache and relogin.

 

Thanks.

 

Answers (2)

Answers (2)

Avatar

Avatar
Validate 1
MVP
_Manoj_Kumar
MVP

Likes

104 likes

Total Posts

301 posts

Correct Reply

97 solutions
Top badges earned
Validate 1
Contributor
Ignite 1
Shape 1
Give Back 5
View profile

Avatar
Validate 1
MVP
_Manoj_Kumar
MVP

Likes

104 likes

Total Posts

301 posts

Correct Reply

97 solutions
Top badges earned
Validate 1
Contributor
Ignite 1
Shape 1
Give Back 5
View profile
_Manoj_Kumar
MVP

02-06-2020

Hello @radhikas2660960 ,

You mentioned that you were getting some error initially that is why you deleted and re-created the schema.

Can you please create it again and then we can look at the schema. May be there was some linking you might have done which is throwing error now because the dependency is lost

Also, Can you click on the show details button on the error dialog box to show the more details and re-share the screenshot?

Avatar

Avatar
Boost 5
Level 2
dhanesh04s
Level 2

Likes

9 likes

Total Posts

19 posts

Correct Reply

6 solutions
Top badges earned
Boost 5
Applaud 5
Ignite 1
Boost 3
Boost 1
View profile

Avatar
Boost 5
Level 2
dhanesh04s
Level 2

Likes

9 likes

Total Posts

19 posts

Correct Reply

6 solutions
Top badges earned
Boost 5
Applaud 5
Ignite 1
Boost 3
Boost 1
View profile
dhanesh04s
Level 2

01-06-2020

Hi @radhikas2660960 ,

Can you post the snapshot of the error you are facing.

 

Thanks,

Dhanesh