Connection to SMS provider does not connect using the Extended generic SMPP connector

Avatar

Avatar

kevinh95689533

Avatar

kevinh95689533

kevinh95689533

15-05-2019

I have configured an external account for the Mobile channel.  I am using the Extended generic SMPP connector.  I have set the SMPP parameters according to the providers specs and have had them whitelist the public IP of the host of our AC instance.

When I execute a delivery I do not get an SMS message and what I see in the logs is the MTA trying to connect repeatedly with no success. (See below)  What configuration am I missing to get this connection to be successful?

  1. 2019-05-15 18:35:15SMPP connection with '************:8143' (***.**.**.**) 7.

  2. 2019-05-15 18:35:15SMPP connection with '************:8143' (***.**.**.**) 7.

  3. 2019-05-15 18:35:15New attempt to establish SMPP connection with '**************:8143'.

  4. 2019-05-15 18:35:15New attempt to establish SMPP connection with '**************:8143'.

  5. 2019-05-15 18:35:15PDU sent to '**********:8143':\nBIND_TRANSMITTER sequence_number=0x00000001\n system_id='*************' password='**********'\n system_type=''\n interface_version=0x34\n addr ton=0, npi=0\n address_range=''\n

  6. 2019-05-15 18:35:15PDU sent to '**********:8143':\nBIND_TRANSMITTER sequence_number=0x00000001\n system_id='*************' password='*******'\n system_type=''\n interface_version=0x34\n addr ton=0, npi=0\n address_range=''\n

  7. 2019-05-15 18:35:15SMPP connection with '************:8143' (***.**.**.**) 4.

  8. 2019-05-15 18:35:15SMPP connection with '***********:8143' (***.**.**.**) 4.

  9. 2019-05-15 18:35:15New attempt to establish SMPP connection with '**********:8143'.

  10. 2019-05-15 18:35:15New attempt to establish SMPP connection with '*********:8143'.

  11. 2019-05-15 18:35:05New SMPP connection attempt in 10 seconds...

  12. 2019-05-15 18:35:05New SMPP connection attempt in 10 seconds...

Accepted Solutions (0)

Answers (0)