Can't see option for "Force the encoding used for messages" in SMTP tab of delivery

Avatar

Avatar

ithrewmypiefory

Avatar

ithrewmypiefory

ithrewmypiefory

28-01-2020

Guru needed

 

We can't see option for "Force the encoding used for messages" in SMTP tab of delivery. (Delivery properties --> SMTP).  

The input schema for nms delivery has not been modified (to our knowledge) and the XML for @forcecodepage is as below.  Could one of the "visibleIf" constraints be causing the issue.  How could we check for that?

 

Any other ideas why we can't see this on our email delivery template? On the SMTP tab we can see the bounce mails section and additional smtp headers section.

 

<!--[of]:SMTP-->
<container label="SMTP" propagateConstraints="false" visibleIf="EV(@messageType, 'mail') and EV(@deliveryMode, 'external', 'descriptive')=false">
<container type="visibleGroup" visibleIf="EV(@messageType, 'mail') and IsUnicode()"
xpath="advancedParameters">
<container label="Character encoding" type="frame">
<input useDesc="true" xpath="@forceCodepage"/>
<container type="visibleGroup" visibleIf="@forceCodepage">
<input xpath="@codepage"/>
</container>
</container>
</container>

 

Please HELP!! 😩

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Milan_Vucetic

MVP

Avatar

Milan_Vucetic

MVP

Milan_Vucetic
MVP

29-01-2020

Hi @ithrewmypiefory,

 

could you check with your DB team if your database is unicode?

You have visibility condition (marked):

<container type="visibleGroup" visibleIf="EV(@messageType, 'mail') and IsUnicode()"

 

Check how to switch to Unicode on https://docs.adobe.com/content/help/en/campaign-classic/using/monitoring-campaign-classic/updating-a...

 

Regards,
Milan

 

 

Answers (0)