Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

azure blob storage integration ACC

ags
Level 2
Level 2

I create an external account with the access key and the host name <myaccount>.blob.core.windows.net but when I try to update a file on transfer activity always get the same log:

03/04/2021 8:22:59 PM              CRL-290182 Error occurred while uploading 'http://<myaccount>.blob.core.windows.net/<container>/<file>.csv' to Azure Blob Storage (code CRL-290030 Not Found - The server has not found anything matching the Request-URI)

03/04/2021 8:22:59 PM              Failed writing received data to disk/application

03/04/2021 8:22:59 PM              BAS-010035 Cannot write to file '' (errno=9, Bad file descriptor).

03/04/2021 8:22:58 PM              CRL-290182 Error occurred while uploading 'http://<myaccount>.blob.core.windows.net/<container>/<file>.csv' to Azure Blob Storage (code CRL-290030 Not Found - The server has not found anything matching the Request-URI)

03/04/2021 8:22:58 PM              Failed initialization

03/04/2021 8:22:58 PM              Starting transfer of '/usr/local/neolane/nl6/var/<myinstance>/export/<file>.csv' to 'http://<myaccount>.blob.core.windows.net/<container>/<file>.csv'

03/04/2021 8:22:58 PM              1 file(s) to transfer

 

 

I'm not sure what is the error, if I configure wrong the account or is a protocol (HTTPS) problem, or may be need add some script code to transfer activity. 

 

I hope someone could help me,

 

Thanks

1 Accepted Solution
ags
Correct answer by
Level 2
Level 2

Hi @LeonieSwart-lonalo it seems to be a related with campaign version, we had to update to  version GS11

View solution in original post

4 Replies
marcinkacz
Level 4
Level 4

Hi ags
Unfortunately AC uses http as default. I'm not sure if this can be changed. Please ask Blob owner/admin to set Secure transfer required to Disabled:

 

marcinkacz_0-1616161651339.png

 

Most probably new Access keys would need to be generated too:

 

marcinkacz_1-1616161651348.png

 

This small change should resolve your issue.

Regards, Marcin

LeonieSwart-lonalo
Level 2
Level 2

Did this resolve your issue?

Any idea on a possible workaround so https is possible?

 

Thanks!

Leonie

ags
Correct answer by
Level 2
Level 2

Hi @LeonieSwart-lonalo it seems to be a related with campaign version, we had to update to  version GS11

View solution in original post