Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Approval Activity redirection link issue

Greeshma_Sampath1
Level 3
Level 3

Hi Team,

 

The approval mail i get is getting redirected to our development url and not on the current environment url.

Sometime the approval redirection is not asking for Yes/No radio buttons also.

How can I change it and where can i find it?

Could someone please help me out in this?

 

Thanks,

Greeshma

1 Accepted Solution
Greeshma_Sampath1
Correct answer by
Level 3
Level 3

Hi @Sukrity_Wadhwa,

 

After resaving the " Notification of the assignees for a workflow task " delivery template again this issue got resolved.

Thanks,

Greeshma

View solution in original post

7 Replies
Deb007
Level 6
Level 6

Hi @Greeshma_Sampath1 ,

 

Can you compare the approval URLs generated from both the environments, if the servers are same or different?

If same, then you need to compare various intranet and internet URLs in deployment wizard of both the environments.

Be very careful when making any changes in deployment wizard.

 

Thanks,

Deb

Greeshma_Sampath1
Level 3
Level 3

Hi Deb007 ,

 

I compared the urls from deployment wizard and the urls are given correctly but still when we click the link from approval mail to give approval its going to the old one.

Have you experienced this issue before and could you please help in resolving this issue?

 

Thanks,

Greeshma

Deb007
Level 6
Level 6

Hi @Greeshma_Sampath1,
Did you manage to compare the following URL(highlighted in yellow) from both the environments.

 

Deb007_0-1620720348281.png

If they are different, can you try to put an approval activity in anew workflow from the environment where you are getting the error/being redirected to different one.

 

Sukrity_Wadhwa
Employee
Employee

HI @Greeshma_Sampath1,

Were you able to resolve this query or do you still need more help here? Do let us know.

Thanks!

Greeshma_Sampath1
Correct answer by
Level 3
Level 3

Hi @Sukrity_Wadhwa,

 

After resaving the " Notification of the assignees for a workflow task " delivery template again this issue got resolved.

Thanks,

Greeshma

View solution in original post

Marcel_Szimonisz
Community Advisor
Community Advisor

Hello @Greeshma_Sampath1 ,

maybe they left the old url in options where the approval base url is taken from. Check if options Nms_xxxURL point to correct url

 

Marcel