adobe encryption fuction(cryptString) does't match with other software code

Avatar

Avatar
Validate 1
Level 1
surabhis2424891
Level 1

Likes

3 likes

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 1
surabhis2424891
Level 1

Likes

3 likes

Total Posts

1 post

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
View profile
surabhis2424891
Level 1

17-09-2019

Hi There,

I've been asked to get a specific Encrypted value through adobe cryptString funtion and I'm not able to. Is there a reason why it will happen and also I'm getting % sign in start of the Encrypted value with escapeUrl and If i don't use escapeUrl I get @ sign in front of Encrypted value.

Also in cryptString (str [, key ] [, useSalt ]) what could be key?

Thanks,
RAJ

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Establish
MVP
wodnicki
MVP

Likes

976 likes

Total Posts

1,096 posts

Correct reply

514 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile

Avatar
Establish
MVP
wodnicki
MVP

Likes

976 likes

Total Posts

1,096 posts

Correct reply

514 solutions
Top badges earned
Establish
Affirm 500
Contributor
Shape 1
Give Back 100
View profile
wodnicki
MVP

24-09-2019

Hi,

The cryptString() function is salted with the time, so will never produce the specific value you've been asked to get.

Key param is the AES encryption key in base 64, defaults to xtk option XtkKey.

Thanks,

-Jon

Answers (0)