Why I am getting "No Matching AAM UUID" after ingesting inbound data files ?

Varun_Kalra

MVP

21-08-2017

Sometimes we upload Customer IDs data on a cross device data source and we know that those CRM IDs have ID synced already. But still when we upload the data file after it's processing we get all the uploaded records in "No Matching AAM UUID" column while checking onbaording status report. How to fix that ?

Accepted Solutions (1)

Accepted Solutions (1)

Varun_Kalra

MVP

21-08-2017

Make sure you have done following checks in AAM UI and in that uploaded file:

1. Trait is an onboarded trait.

2. Data Source is Cross Device + Inbound.

3. Trait expression should be similar to "key"="value" pair in the inbound file.

4. There should not be any unnecessary white space or return in the inbound file.

5. Make sure there is a <TAB> just after the Customer ID in every record of file, and never use whitespace instead of <TAB>.

6. If there are any special characters in the Customer ID, then consider their URL encoding while passing those from front end while ID syncing, as mentioned in this doc : CID Replaces DPID and DPUUID

In order to investigate this issue we can do following steps :

1. Do an ID sync of few test IDs or have some test CRM IDs and log in on your site/app with them, so that those CRM IDs get an AAM UUID or MID linked with it.

2. After few hours of ID syncing, create a data file with those CRM IDs and add some "key"="value" pairs of an existing or newly created onboarded trait.

3. Upload the file and add your email address for that Data Source to get notifications for onboarding status from AAM UI > Analytics > Onboarding Status report.

4. Check if you are able to get data ingested with matched UUIDs, if not then report to AAM Client Care : Contact and support information for Adobe Marketing Cloud.

P.S. If you have created a new trait, allow it 2-3 hours for propagation before uploading data in it.

Answers (0)