Visitors having visit truncated every pageview??

Avatar

Avatar

JarrodD

Avatar

JarrodD

JarrodD

08-09-2020

We're seeing some very unusual data across a handful of our reports where some visitors coming to our site are somehow appearing as multiple unique visitors and/or multiple visits (multiple meaning 20-30+ "visits" with 1 visit per 1 pageview) in the span of 1-3 hours, which is obviously impossible.

 

I've been able to confirm the issue from a few angles by collecting an internal user ID via an eVar (the website is behind a login, so we know who the visitors are) and we are seeing quite a few visitors that appear in analytics as multiple uniques but are linked to a single internal user ID (per visitor) in the eVar report with some having 40-60+ unique visitors per internal user id.

 

Digging into the issue further, the same traffic also shows very unusual data in the browsers report where one visitor will be linked to Google Chrome, Internet Explorer, and often times multiple versions of each all in the same time of just a few hours. The visitor domains report similarly shows extremely unusual data with these visitors appearing linked to 5-10+ different domains - many of which aren't even active domains.

 

We have bot filtering activated and I've tested the site with Charles, the Adobe Debugger and a number of other tools and everything I see looks correct in terms of the Visitor ID. The tools we have deployed via Adobe Launch are Analytics & Target (with A4T) with the Visitor ID service all configured with first-party CNAME's. I also validated the SDID's for A4T are populating correctly and they also appeared to be working fine.

 

Any idea what could be causing this and how we can resolve it?

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar

JarrodD

Avatar

JarrodD

JarrodD

08-09-2020

I confirmed the traffic is indeed legitimate by using the internal user ID I mentioned above that I collected into an eVar.

 

One of the top domains the affected visitors are showing up from is amazonaws.com which made me think it was bot traffic at first as well. But after reviewing closer, it is indeed legitimate. Is there any kind of misconfiguration in the Adobe Visitor ID service when using first-party CNAME's or perhaps something to do with caching on the Adobe side?

 

I ask about caching because I can't fathom any other reason why a single visitor (identified by the internal login user ID eVar I mentioned above) in Adobe Analytics would show as having used 13 (!) different browsers (Safari, Chrome Mobile 84.0, Google Chrome 85.0, Chrome Mobile 83.0, Safari 13.0, Google Chrome 84.0, Safari 13.1.2, Samsung Browser 12.1, Microsoft Internet Explorer 11, etc etc). 

 

Even more confusing is that the actual pages and pathing these visitors are hitting looks very normal otherwise. I've even looked into numerous types of browser add-ons including ad blockers and anti-fingerprinting extensions (since some of those randomize browser identity/characteristics) and other similar items and the amount of visitors this is affecting combined with the legitimate behavior otherwise of the traffic makes those both very unlikely as well.

Avatar

Avatar

Andrey_Osadchuk

MVP

Avatar

Andrey_Osadchuk

MVP

Andrey_Osadchuk
MVP

08-09-2020

Did you look up the suspicious User IDs in the backend system to validate whether they look to be real users or bots?