Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Segment which excludes Unspecified Unique Visitors working in Workspace, but not in Report Builder

Avatar

Avatar
Level 1
SDJCox
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile

Avatar
Level 1
SDJCox
Level 1

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile
SDJCox
Level 1

26-05-2020

Hey Everyone!

I have created a segment which successfully excludes Unspecified Unique Visitors from a desired report within Analysis Workspace, however when adding this same segment to a Report Builder file we see a slightly higher number of Unique Visitors in our total which we attribute to being some Unspecified which is somehow not being filtered out.

Does anyone have any idea how we can remove this Unspecified in Report Builder? And why it would work in Workspace but not in Report Builder?

Thanks!

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Shape 1
Level 2
ForgotPassword4Times
Level 2

Likes

9 likes

Total Posts

54 posts

Correct Reply

6 solutions
Top badges earned
Shape 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile

Avatar
Shape 1
Level 2
ForgotPassword4Times
Level 2

Likes

9 likes

Total Posts

54 posts

Correct Reply

6 solutions
Top badges earned
Shape 1
Boost 5
Boost 3
Boost 1
Applaud 5
View profile
ForgotPassword4Times
Level 2

27-05-2020

Have you tried building the segment on '::unspecified::'?  The api value thats used includes some extra characters that are not visible within analysis workspace.

Avatar

Avatar
Affirm 25
Level 4
kainth
Level 4

Likes

49 likes

Total Posts

117 posts

Correct Reply

26 solutions
Top badges earned
Affirm 25
Give Back
Boost 5
Boost 3
Boost 25
View profile

Avatar
Affirm 25
Level 4
kainth
Level 4

Likes

49 likes

Total Posts

117 posts

Correct Reply

26 solutions
Top badges earned
Affirm 25
Give Back
Boost 5
Boost 3
Boost 25
View profile
kainth
Level 4

26-05-2020

Hi @SDJCox,

 

Workspace & Report Builder treats Unspecified line item differently. So, if you want to let's say filter the users for whom the Products variable for not set then you can filter those user using the segment condition "Product Exisits" as shown below.

 

kainth_0-1590522927275.png

 

Hopefully, that should resolve the issue.

 

Regards,

Abhinav