iOS - Inconsistent page views & occurrence shows more than what's expected.

Avatar

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile
arvbhavan
Level 1

20-07-2021

Hi Team,

 

I have been testing out ACP iOS SDK's in a sample iOS app with only one screen (to track a page view) and button (to track action). I have actually appended a counter value to both `page names` and `action names` (Counter starts from zero and count is persisted even if the app is killed and launched again) - so I am expecting to see each page visit and action only once in the Adobe portal.

 

I have enabled debug logging for the sample app and have inspected the console logs to make sure the track action and track state logs are as expected.

 

I have observed the below behavior:

 

Action names: I am seeing all the action names as expected in the portal - one action name reported exactly once.

 

Page names: I am seeing inconsistency in the occurrences of page views shown in the adobe portal, sometimes the page views do not show up at all where as I am sure its definitely logged in the console logs and send successfully from the app.

Most of the times the page views are shown more than what's expected (two to three fold).

 

Have we experienced this issue before ? Any assumptions on whether any mobile launch property / report suite configuration or even the extensions added that could cause this inconsistent behaviour ?

 

Regards,

Aravind

 

 

Accepted Solutions (0)

Answers (3)

Answers (3)

Avatar

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile
arvbhavan
Level 1

21-07-2021

Hi @PratheepArunRaj - Its just a sample application.

 

The initialisation code is registering the below extensions:

 

`UserProfile, Lifecycle, AEPIdentity.Identifty and Analytics` and in the completion calls MobileCore.configureWith(appID: "ID goes here")

 

Its just a one screen application that does MobileCore.track(state: "Page name", data: nil)

 

Could anything in configuration be causing this issue ?

Avatar

Avatar
Seeker
Moderator
PratheepArunRaj
Moderator

Likes

316 likes

Total Posts

871 posts

Correct reply

265 solutions
Top badges earned
Seeker
Bedrock
Engage 1
Affirm 250
Contributor
View profile

Avatar
Seeker
Moderator
PratheepArunRaj
Moderator

Likes

316 likes

Total Posts

871 posts

Correct reply

265 solutions
Top badges earned
Seeker
Bedrock
Engage 1
Affirm 250
Contributor
View profile
PratheepArunRaj
Moderator

21-07-2021

Dear arvbhavan,

Connect with me, I can help you on this. We need to validate both the Launch Configuration and the App Level implementation to close this.

Thank You, Pratheep Arun Raj B | Xerago | Terryn Winter Analytics

Avatar

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
arvbhavan
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
View profile
arvbhavan
Level 1

20-07-2021

I also would like to ask whether you could provide us with a trial/test-only mobile launch property - so I could repeat this tests to use that configuration id ? Alternatively I am happy to privately share across a sample dashboard with the results that I am seeing and the configuration id used to initialise the Adobe SDK from the app.