Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Image beacon will be processed at Adobe server?

Avatar

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile
dinesh_kumar_r
Level 2

02-08-2019

Hi Team,

I firing image beacon using Ensighten built in method as shown below.

Bootstrapper.imageRequest("//met2.hp.com/b/ss/hphqglobal,hpi-hphqelite1.0/1/JS-1.4.4/s"+a+"?s.eVar81="+eVar81);

I am able to see the image beacon firing on the page as shown in the attachment, but I am not seeing the data in the workspace. Please reply asap.

sc_image_beacon.png

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

522 likes

Total Posts

943 posts

Correct Reply

254 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

522 likes

Total Posts

943 posts

Correct Reply

254 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile
Andrey_Osadchuk
MVP

02-08-2019

Hey Dinesh,

The syntax for s.eVar is incorrect. This type of variables should be passed to the collection server as "v" query string parameter.

Consider the following syntax instead:

Bootstrapper.imageRequest("//met2.hp.com/b/ss/hphqglobal,hpi-hphqelite1.0/1/JS-1.4.4/s"+a+ "?v81="+eVar81);

Answers (4)

Answers (4)

Avatar

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile
dinesh_kumar_r
Level 2

03-08-2019

Hi Andrey,

if we pass "#" in the products variable, after "#' values are getting truncated. See below example.

products = "abcd#uzzz";

Bootstrapper.imageRequest("//met2.hp.com/b/ss/hphqglobal,hpi-hphqelite1.0/1/JS-1.4.4/s"+a+ "?products="+products);

In the image beacon,we are seeing only values before #, nothing after #.

products = abcd.

Please help me here.

Avatar

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile

Avatar
Validate 25
Level 2
dinesh_kumar_r
Level 2

Likes

12 likes

Total Posts

95 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Boost 5
Applaud 5
View profile
dinesh_kumar_r
Level 2

03-08-2019

Thank you @Andrey , its working now. I changed s.eVar81 to v81.

Avatar

Avatar
Coach
MVP
ursboller
MVP

Likes

520 likes

Total Posts

1,020 posts

Correct Reply

256 solutions
Top badges earned
Coach
Contributor
Bedrock
Seeker
Springboard
View profile

Avatar
Coach
MVP
ursboller
MVP

Likes

520 likes

Total Posts

1,020 posts

Correct Reply

256 solutions
Top badges earned
Coach
Contributor
Bedrock
Seeker
Springboard
View profile
ursboller
MVP

02-08-2019

Thanks Andrey Osadchuk​ for pointing on the eVar, guess I stopped checking after the domain...

Avatar

Avatar
Coach
MVP
ursboller
MVP

Likes

520 likes

Total Posts

1,020 posts

Correct Reply

256 solutions
Top badges earned
Coach
Contributor
Bedrock
Seeker
Springboard
View profile

Avatar
Coach
MVP
ursboller
MVP

Likes

520 likes

Total Posts

1,020 posts

Correct Reply

256 solutions
Top badges earned
Coach
Contributor
Bedrock
Seeker
Springboard
View profile
ursboller
MVP

02-08-2019

doesn't look bad, but it is sent to "met2.hp.com"

do you have cname enabled or anything to forward the request to adobe?