Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Data Warehouse API returning inflated data

Avatar

Avatar
Validate 1
Level 1
chrisalvarespmg
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
chrisalvarespmg
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
chrisalvarespmg
Level 1

15-09-2020

As of Saturday, any request made using the Data Warehouse API's Report.Queue has been returning considerably more data (roughly 10x more rows), inflating numbers when selecting more than 3 dimensions. When duplicating the report inside of Data Warehouse and setting the target to "email", the numbers return to normal, however, any request made using the API returns significantly more data.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 5
Employee
ankits28281247
Employee

Likes

21 likes

Total Posts

80 posts

Correct Reply

24 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Boost 5
Boost 3
View profile

Avatar
Give Back 5
Employee
ankits28281247
Employee

Likes

21 likes

Total Posts

80 posts

Correct Reply

24 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back
Boost 5
Boost 3
View profile
ankits28281247
Employee

15-09-2020

@chrisalvarespmg  Can you provide more details, like what request you are making from data warehouse API and response you are getting that will help us in debugging the issue. 

Answers (2)

Answers (2)

Avatar

Avatar
Affirm 25
Employee
Khurshid_Alam
Employee

Likes

55 likes

Total Posts

188 posts

Correct Reply

41 solutions
Top badges earned
Affirm 25
Boost 50
Affirm 10
Boost 25
Affirm 5
View profile

Avatar
Affirm 25
Employee
Khurshid_Alam
Employee

Likes

55 likes

Total Posts

188 posts

Correct Reply

41 solutions
Top badges earned
Affirm 25
Boost 50
Affirm 10
Boost 25
Affirm 5
View profile
Khurshid_Alam
Employee

16-09-2020

Can you try without currentData? May be that is causing the issue.

Avatar

Avatar
Validate 1
Level 1
chrisalvarespmg
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
chrisalvarespmg
Level 1

Like

1 like

Total Posts

8 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
chrisalvarespmg
Level 1

15-09-2020

Here is the request: 

Report.Queue: 

"reportDescription": {

    "reportSuiteID": "<redacted>",

    "dateFrom": "2020-09-08",

    "dateTo": "2020-09-13",

    "dateGranularity": "day",

    "metrics": [{

        "id": "revenue"

    },

    {

        "id": "visits"

    },

    {

        "id": "orders"

    },

    {

        "id": "allvisitors"

    }],

    "elements": [

    {

        "id": "mobiledevicetype",

        "everythingElse": true

    },

    {

        "id": "evar1",

        "everythingElse": true

    },

    {

        "id": "referringdomain",

        "everythingElse": true

    },

    {

        "id": "trackingcode",

        "everythingElse": true

    },

    {

        "id": "visitnumber",

        "everythingElse": true

    }],

    "locale": "en_US",

    "currentData": true,

    "source": "warehouse",

    "elementDataEncoding": "utf8"

    }

}

Report.Get 
{
     "reportId": "<redacted>"
     "format": "csv",
     "page": 1 //1,2,3,4,5,6,7, etc
}