AEM - Adobe launch and analytics integration

Avatar

Avatar

piyusha55649946

Avatar

piyusha55649946

piyusha55649946

16-07-2019

Hi Team,

            I am facing issue in getting the user action data flowing from AEM webpage to adobe analytics through adobe launch.

Here is what I am doing:

1. In AEM web page, I have configured the data layer containing static data and included the launch java script.

2. Configured the data elements / rules and analytics extension in the launch and also configured the rules to copy data from data elements in evars and send becon rule as well.

I feel copying the data elements and send becon in launch should take care of sending real time data to analytics report suites.

However, even after these steps, the data is not getting reflected in analytics real time reports.

Need some urgent help in the same pls.

Regards,

Piyush

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Balaji_V

Avatar

Balaji_V

Balaji_V

16-07-2019

Hi Piyush,

As a best practice, the configured data layer should have been available before launch javascript

Send Beacon rule condition should have been followed anyone steps given below;

Page bottom

Window loaded

Direct Call

Please refer the videos in the link for your understanding

https://helpx.adobe.com/analytics/kt/using/data-layer-set-variables-launch-technical-video-implement...

Try this and let me know

Thanks,

Balaji

Answers (1)

Answers (1)

Avatar

Avatar

kumararajak

Avatar

kumararajak

kumararajak

16-07-2019

Hi Piyush,

Check this link for details to integration issue

SiteCatalyst integration troubleshooting issues

Regards,

Kumararaja K