Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Adobe Call not happening

Avatar

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
Level 1

04-06-2021

Hello, 

 

We have configured a button that is populating via Adobe Launch for every page load rule as below:

jsvasu_2-1622819055109.png

 

The button is populating on all pages exactly the way we wanted it to be however there is no call happening to Adobe Analytics when we are clicking on the button. I have checked it in the Network of the developer console window, which ideally I guess it should. 

jsvasu_0-1622818813375.png

 

So at this node, I wanted to confirm, Do we have to do set up a "Send Beacon" here like that ?

jsvasu_1-1622819017115.png

Best

 

 

 

Accepted Solutions (0)

Answers (5)

Answers (5)

Avatar

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
Level 1

07-06-2021

@Andrey_Osadchuk @irama987596 

The integrated button on the website actually has a configuration that says we just have to create "success events" in analytics and map them into Feedback Tool's Web Account as below. We are not supposed to build any click event rules to capture as per the button's configuration. 

 

Success Events Created in Analytics:

jsvasu_0-1623081364988.png

This is how they are mapped in Feedback Tool's Web account:

jsvasu_1-1623081476387.png

 

 

We are bringing this Feedback button as a page load rule via Launch so that it appears on every page. As per the tool when if a feedback button will get clicked the counter-event will automatically capture the count, and similarly when user will complete the feedback, the counter-event will capture the count. However, we are not seeing any Adobe calls"b/ss/" happening, which usually happens to get in like below:

jsvasu_2-1623081827650.png

This is something the Feedback Tool vendor has tested in their test environment and they are successfully getting the events triggered at their end for every feedback start/success. Can there be any issue with the Staging Environment where we are testing? What could be the best possible solution to it? Any suggesstions?

 

Avatar

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

523 likes

Total Posts

943 posts

Correct Reply

254 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

523 likes

Total Posts

943 posts

Correct Reply

254 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile
Andrey_Osadchuk
MVP

06-06-2021

Hi @jsvasu ,

The rule you shared in the screenshot adds a button. You are looking for a way to send an AA beacon on button click. Add another rule with the Mouse Click event targeted to the added button, and trigger an AA beacon in the Actions.

 

Avatar

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile

Avatar
Give Back
Level 1
jsvasu
Level 1

Likes

0 likes

Total Posts

30 posts

Correct Reply

0 solutions
Top badges earned
Give Back
View profile
jsvasu
Level 1

04-06-2021

@HemanginiS and @irama987596 Thanks, maybe I need to be more elaborative. Even after setting the s.tl() my purpose is not getting solved.

I don’t see the Analytics call getting triggered in the developer console window when a user clicks
that Feedback Button (which means the feedback is opened) on my page.
This is how I set it up now. I guess from this setting adobe call is happening for page load, not for click on the
feedback button. Any help on that?

jsvasu_1-1622833004008.png

I want to adobe call to happen when the user will click that Feedback Button on my web page

jsvasu_2-1622833458223.png

Thanks

 

 

Avatar

Avatar
Employee
irama987596
Employee

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile

Avatar
Employee
irama987596
Employee

Likes

0 likes

Total Posts

2 posts

Correct Reply

0 solutions
View profile
irama987596
Employee

04-06-2021

That's correct. You need to add Send Beacon action. Choose s.t() if it's page view, otherwise choose s.tl() for CTA interactions.

Avatar

Avatar
Affirm 5
Level 3
HemanginiS
Level 3

Likes

21 likes

Total Posts

43 posts

Correct Reply

14 solutions
Top badges earned
Affirm 5
Affirm 3
Boost 10
Affirm 1
Establish
View profile

Avatar
Affirm 5
Level 3
HemanginiS
Level 3

Likes

21 likes

Total Posts

43 posts

Correct Reply

14 solutions
Top badges earned
Affirm 5
Affirm 3
Boost 10
Affirm 1
Establish
View profile
HemanginiS
Level 3

04-06-2021

Hi @jsvasu ,

If you want to trigger an Analytics beacon when this rule fires then you need to add sendbeacon action in this rule.