Highlighted

Incorrectly Configured Event?

richardk8816057

25-06-2018

I configured an analytics success event to count a specific number of items. At times the analytics success event counts my items correctly. However, there is a margin of error with my analytics success event.

I have backend system data to use as a comparison point, but the margin of error has continued to grow. I know asynchronous and synchronous databases will never match 1:1. That being said, the magnitude of the difference is unacceptable.

Success Events

(eventX)

Type=counter

Unique Event Recording: Always Record Event

Polarity and Visibility are NOT configured.

Has anyone ran into this issue before? Helpful resolutions?

Thanks in advance...

Replies

Highlighted

pabloc82923542

25-06-2018

There are several factors that could be at root here. Some more clarity on the event type and how its triggered would help.

Is it a product tallying event? Is it more a transactional type of event? What backend type of system? SAP or SQL are you comparing it too? Is it a  link or button click triggered event? Some other type of event like a signup?

1 The event if its trigger based is there any reliance to any sort of cookie? If so then users browser settings may be a cause.

2 The event could the action of a user book marking a page cause the event to refire if a user bookmarks or reloads the page?

3 Could you have a code race issue. I mean is it possible the page fires the beacon before the event and its child elements if applicable is given time to populate

Highlighted

richardk8816057

26-06-2018

pabloc82923542

The event is not cookie based. The event counts the number of times an "application" is started. The event can only fire once per visit. A reload will not effect the count otherwise the "application" count would be overstated.

The "application" count is understated. It is as if something blocks (inhibits) the analytics event from firing all the time.

Any additional thoughts?

Highlighted

pabloc82923542

26-06-2018

Ok then I would check based on your logic from back end to Adobe Analytics if how users access App might be missing start up of APP.

1 First launch

user logs in starts APP( I am guessing this is ok and fires correctly.)

2 Reload of APP (You mention will not re fire event so we are good here)

3 What happens if a user bookmarks a page and later after visit session is done? Does Beacon fire then?

4 Does your APP have a Race condition, this means does the beacon fire completely and to fast before the event can be triggered/captured and sent all the time?

Is this a single page APP like in Angular? Also The event is it built custom inpage or via DTM?

Highlighted

richardk8816057

26-06-2018

pabloc82923542

1. I see the analytics event successfully fires when testing.

2. Reloads do not cause an issue.

This application is multiple page architecture - it is not SPA. Also, the event is built custom inpage and not through DTM.

I need to research items 3/4 in more depth.

Highlighted

Gigazelle

Employee

17-07-2018

What percent margin of error are we talking here? Is one always higher than the other?

I wonder if the issue is not in your implementation at all, but rather some people using Analytics-blocking extensions.