Highlighted

Adobe Launch Video Percent Tags- Firing multiple times

Avatar

Avatar

ericm57629209

Avatar

ericm57629209

ericm57629209

30-11-2018

Hello All!

We recently migrated from DTM to Launch. We created video rules to capture percent played (25, 50, 75, 200) along with Video Start and Complete. Our issue is the percent tags seem to be firing multiple times.

When debugging it looks like they're firing alongside each other. So the 25% is firing once @ 25, then at 50, again at 75, etc.

I couldn't figure a way to create rules logic that says "fire 25% tag ONLY for the initial 25% played".

Any thoughts from the A Community?

Thanks for the help!

Replies

Highlighted

Avatar

Avatar

Waqas_Rafiq

Avatar

Waqas_Rafiq

Waqas_Rafiq

04-12-2018

Hi,
Is it a SPA that the video is on? Might be worth running s.clearVars once the event has fired with 25% to ensure that data is cleared before the next request on 50% is made? haven't worked with Launch and Video tracking, but sounds like that's the issue here. The event is staying persistent.   The s.clearVars() Function  

Highlighted

Avatar

Avatar

Waqas_Rafiq

Avatar

Waqas_Rafiq

Waqas_Rafiq

04-12-2018

There is also this blogpost that goes into more detail about the setup:Digital Analytics Insight: HTML5 Video Tracking using Launch by Adobe

Highlighted

Avatar

Avatar

ericm57629209

Avatar

ericm57629209

ericm57629209

04-12-2018

Thank you Waqas! Looks like we needed to add another action set to "Clear Variables" in the Adobe Launch Rule. That seemed to make each tag fire once per video play. I appreciate the comment.

Highlighted

Avatar

Avatar

Waqas_Rafiq

Avatar

Waqas_Rafiq

Waqas_Rafiq

04-12-2018

Good to see that worked out.