ReferenceError: guidelib is not defined

twoLait 27-10-2018

Hi,

I have a fresh instance of AEM 6.2  + (hotfix and SP1 ) and I'm having this issue when loading a page a pop up windows appear: An error occurred, please check the browser console for more details.

and this error on the browser console:

Handler of component is invalid -> ReferenceError: guidelib is not defined

    at eval (eval at ns.util.sanitizeCQHandler (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...), <anonymous>:1:1)

    at Object.ns.util.sanitizeCQHandler (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...)

    at String.<anonymous> (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...)

    at Function.each (http://localhost:4502/etc/clientlibs/granite/jquery.min.fb50358df4c2bd6aa6e1dd5b0d9b9d29.js:376:19)

    at constructor._loadConfig (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...)

    at constructor.updateConfig (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...)

    at Object.<anonymous> (http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/core.min.90f7753c94fb45b35...)

    at fire (http://localhost:4502/etc/clientlibs/granite/jquery.min.fb50358df4c2bd6aa6e1dd5b0d9b9d29.js:3232:31)

    at Object.fireWith [as resolveWith] (http://localhost:4502/etc/clientlibs/granite/jquery.min.fb50358df4c2bd6aa6e1dd5b0d9b9d29.js:3362:7)

    at done (http://localhost:4502/etc/clientlibs/granite/jquery.min.fb50358df4c2bd6aa6e1dd5b0d9b9d29.js:9840:14)

For now the only confirmed bad behavior of the instance is that it takes about 30 seconds to load an empty page.

I found these two posts on the forum without resolving my problem:

Handler of component is invalid -&gt; ReferenceError: guidelib is not defined

AEM Template editor &amp; Experience Fragments

Any help will be appreciated.

Accepted Solutions (1)

Accepted Solutions (1)

twoLait 29-10-2018

Issue resolved as follows:

I reinstalled the instance using a different aem-service package, so - instead of AEM-6.2-Service-Pack-1-6.2.SP1 from package share; i installed another version that I already had from about a year ago.

I cannot asure that the package share version was the culprit - it could be that the first installation of the three packages (hotfix, aem-service and cq-6.2.0-sp1-cfp-5.0) produced the issue for any unknown reason.