Need for Backward Compatibility Package - CQ 5.6.1 to AEM 6.4 Migration

nileshdchavan 25-07-2018

hello,

We are migrating from CQ 5.6.1 to AEM 6.4. As a part of making sure we do not have any broken functionality in AEM 6.4, we would like to check if there are any features which are deprecated and can be fixed using the backward compatibility package.

For doing this, we would like to know how do we go about finding -

1. The features that would work by installing the backward compatibility packages

2. the features that wont work even after installing the backward compatibility package and need custom code changes to handle this situation.

I checked the article - Backward Compatibility in AEM 6.4 , but this talks mainly about the package itself and its need. Nothing about how to find if we need backward compatibility package.

It would be great if any of you can guide on approach to determine on above mentioned points. Your help is greatly appreciated.

Thanks!

Nilesh.

Mark Solution

Are these answers useful?
Help other community members by marking useful answers as accepted.

Accepted Solutions (0)

Answers (1)

Answers (1)

smacdonald2008 25-07-2018

One thing you need to do is to rebuild all of your OSGi services with AEM 6.4 libs - including the AEM UBER 6.4 JAR. Code written in 5.6 most likely will not run in AEM 6.4. For details about 6.4 UBER JAR - see - Creating an Adobe Experience Manager 6.4 Project using Adobe Maven Archetype 13

JSP components should be ported to HTL component and Sling Models.

There is a lot of changes in 6.4 vs 5.6 and the WKDK tutorial (link below) will cover these changes - like editable templates, policies, HTL components, Maven projects, etc.

To get up to speed on developing AEM 6.4 projects - i strongly recommend that you do all 6 parts of the WDK tutorial - Getting Started with AEM Sites - WKND Tutorial