Login page is not being displayed in AEM 6.4. Throwing Null Pointer Exception in HtmlLibraryManagerImpl load libraray

pankajkdhingra 27-08-2018

Login page and other pages on AEM6.4 Environment are not being displayed. It was working properly but suddenly it is not working. able to login in CRX/de/index.jsp but no HTML pages are being rendered. Have tried restarting the servers and deploying old releases.


Exception in logs

  1. 27.08.2018 14:44:26.314 *ERROR* [0:0:0:0:0:0:0:1 [1535361266176] GET /libs/granite/core/content/login.html HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl service: Uncaught SlingException

java.lang.NullPointerException: null

                at com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl.loadLibrary(HtmlLibraryManagerImpl.java:1090) [com.adobe.granite.ui.clientlibs:1.0.76]

                at com.adobe.granite.ui.clientlibs.impl.HtmlLibraryManagerImpl.loadLibs(HtmlLibraryManagerImpl.java:1031) [com.adobe.granite.ui.clientlibs:1.0.76]

Accepted Solutions (1)

Accepted Solutions (1)

pankajkdhingra 07-09-2018

We restored the environment from backup and deployed the latest build again. It worked fine. We could not troubleshoot the reason behind the issue or what fixed it but it is working now.

Answers (7)

Answers (7)

kautuk_sahni
Community Manager
07-09-2018

I could recall some similar issue reported on Forums for AEM 6.2 as well. Forced compiling worked that time.

Please follow How to force a recompilation of all Sling scripts jsps, java, and sightly in AEM 6.4  and check this this works.

It was then some datastore corruption issue.

pankajkdhingra 27-08-2018

We installed a code package but it worked properly that time. We deployed a package on Friday morning. It worked welll. but on Sunday afternoon, it started giving this issue.

Really surprised. We reverted the packages deployed on thursday and friday but still issue persists. We have restarted the system twice after deploying old package but it is still giving same issue.

No HTML page : sites.html, editor.html, login.html is appearing.

In Friday change, We introduced listeners.js in server libs

edubey 27-08-2018

1. You may want to share complete logs

2. Can you try login to felix console localhost:4502/system/console/bundles and see if there is any bundle which is not active

3. Was there any deployment which caused this?