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Lab Overview 
 
The goal is of this lab is to guide you through Adobe Audience Manager implementation using Server-Side 
Forwarding method. We will be using Adobe Launch – Adobe’s Tag Management System to implement and 
configure AA, AAM and Experience Cloud ID service 
 

Objectives 
 Adding Adobe Analytics (AA) extension in Launch with Audience Management Module. 
 Implementing Customer ID sync using Experience Cloud ID service tool. 
 Setting up extensions, adapters, environments and libraries. 
 Discussing offline data ingestion flow. 
 Working with DCS api with d_cts flag. 

 

Getting started 
 Find L768 user on the screen to login 
 Use Google Chrome to access the sample website and Experience Cloud UI. 
 Your sign in ID for Adobe Experience Cloud sandbox environment is: 

L768+<seat##>@adobeeventlab.com 

Note: Adobe Experience Cloud credentials will be deactivated after summit. 
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Starting and Accessing the test site 
 

1. Launch a terminal window. You can do this by hitting cmd + space, then 
typing terminal in spotlight search, and hitting enter. 

2. Change the directory to Desktop: 
cd desktop/samplesite 

3. Start the node js server by following command: 
http-server 

4. The sample site will now start and you can access it from your browser with http://localhost:8080 

5. You can edit the HTML files using Text Edit or Brackets application later. 
 

Prerequisites 
 
1. A website with log in functionality (CRM ID). 

2. Experience Cloud Visitor ID service. 

3. Server-side forwarding requires: 
Appmeasurement.js code library (version 1.5 or newer) 
AppMeasurement_Module_AudienceManagement.js 
Experience Cloud Visitor ID service  

4. AA, AAM and Launch as a part of one Experience Cloud Org account. 

5. Admin access for AA, AAM, and Launch via Experience Cloud. 

6. A Report Suite in Adobe Analytics. 

7. A Cross Device Data Source in Audience Manager. 
  

http://localhost:8080/
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Chapter 1: Setting Up Server Side Forwarding for Report Suite in Analytics 
 
In this Chapter, we will turn on SSF on Report Suite level within Adobe Analytics UI. Then we will set up the 
AppMeasurement Library code. 
 

Task 1: Sign in to Experience Cloud using your Adobe ID 
 

i. Your Adobe ID is in the format L768+<seat##>@adobeeventlab.com for example if your seat number is 
5 then use: L768+05@adobeeventlab.com 

ii. URL for sign in to Experience Cloud:  https://aamlab.marketing.adobe.com 
 

 
 

iii. Once you sign in, you will see feeds by default. You can click on the application switcher (9 dots) at the 
top right-hand side corner to access required application’s UI. 

  

https://aamlab.marketing.adobe.com/


 
 
 

6 | L768                     Implementing AAM with Customer ID sync using Launch 

iv. Choose Analytics from the resulting navigation menu. 

 

 
 

Task 2: Enable Server Side Forwarding (SSF) in Adobe Analytics 

Note: The Report Suite has already been created for you. So, you can just check the report suite with the 
name: seat<##> and get the report suite ID and enable SSF. Example Report Suite ID: aamlabseat01 
To learn how to create a Report Suite, please see Addendum 1. 
 

i. While logged into Analytics, click on Admin > Report Suites  
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ii.  Select your Report Suite from the list and note down your Report Suite ID for later. 

 

Go to Admin > Report Suites > Select your Report Suite from the list > Hover over General > Click on Server 
Side Forwarding: 
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iii. Then you will be redirected to the following page, where you will see a check box for SSF. 
Check Enable Server Side Forwarding and click on Save, and then Confirm. 

 

Task 3: Editing Appmeasurement Library code 

Note: The required library code is present on your Mac, so no need to download. Go to Desktop > Assets 
> AppMss.js. However, this code needs to be edited with your AA and AAM account settings. 
To know how to download and merge code libraries, check Addendum 2. 

Open the AppMss.js file in Text edit or Brackets, and edit following values (only the first value i.e. Report Suite 
ID needs to be added by you, rest three values are already there in the file): 

i. For the variable, s_account enter your report suite id as its value. (Example: aamlab<seat##>) 
ii. For the variable s.visitor, we are using Experience Cloud Org ID. The value for s.visitor is: 

856D3EA75A7065040A495C1E@AdobeOrg 
iii. For partner under AAM set up code, we are using this value (AAM subdomain): aamlab 
iv. For the variable s.trackingServer, we are using the value: aamlab.sc.omtrdc.net 
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Now that you’ve made the necessary changes, save the file. You’ll also need to copy the contents of this file to 
be pasted inside Adobe Launch in a later step. 

The final AppMss.js file should look like following: 
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Chapter 2: Installing AA and Experience Cloud ID extensions in Launch, by Adobe 
 
In this Chapter, we will be setting up Adobe Analytics (AA) extension in Launch with Appmeasurement Library 
code. Then we will set up Experience Cloud ID service. 
 

Task 4: Creating web property and installing extensions 

i. Access Launch from Experience Cloud UI. Click on the application switcher > Activation > Hover 
over the Launch Card > Click Enter 
Alternatively, you can access this URL to access Launch: https://launch.adobe.com 
 

 

 

  

https://launch.adobe.com/
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ii. Click the Add New Property button: 
 

  
 
 

iii. Name your property with whatever you would like. You can use same name as your report suite. 

 
 

iv. Use example.com as the domain name, or enter any test domain name there, since our website is 
hosted locally. 

v. Keep Advanced Settings as default and click Save. Your new property should display in the list of 
properties. 
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Task 5: Installing and setting up Adobe Analytics Extension 

i. Click on your Web Property name from the list and go to Extensions tab  Catalog and install the 
Adobe Analytics extension. 

 
 

ii. Under Library Management > Select the last option that says Let me provide custom library code. 
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iii. Click on </> Open Editor and copy the code that you set up in Chapter 1 Task 3 from AppMss.js file 
and paste that code in the window, and save. 

 
 

iv. Scroll down and expand General, then under tracking server enter your tracking server and then 
Save Extension:  

 

Optionally, you can expand the global variables section to add global values to variables like pagename, 
evars and props. 
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Task 6: Installing Experience Cloud ID service 
i. After saving the previous extension, you’ll be taken to the Installed Extensions page. We will be 

installing another extension so return to the catalog by clicking the Catalog button. 

 

ii. Install Experience Cloud ID Service just as you did with the previous extension. You can leave the 
default settings and click Save to finish the install. 

 

Next, we need to define some actions for these extensions to take and set conditions for those actions. 
We will do this in the next chapter with rules and data elements.  



 
 
 

15 | L768                     Implementing AAM with Customer ID sync using Launch 

Chapter 3: Creating Data Elements and Defining Rules 
In this Chapter, we need to create a Data Element that captures the Customer ID when the user signs in to the 
website. We will then create rules to fire Analytics Beacon and get the Customer ID in Experience Cloud Visitor 
ID call. 
 

Task 7:  Identifying Customer ID variable for Authenticated User 
i. When a registered user signs in to the site, then they may use their username or email address. But, 

in that site’s CMS database, that user is identified and stored as a Customer ID or a CRM ID. 
 

ii. This Customer ID is responsible for maintaining a customer’s session and their details might be 
keyed off this ID in your CRM. The customer ID in a browser can be stored in local storage, Cookie, JS 
variable or a hidden HTML element. We need to find out the variable that is keeping this Customer 
ID and then we can use it as a Data Element. 
 

iii. For this lab session, we have a simple website with log in functionality, that stores the Customer ID 
in browser’s Local Storage. The variable that is storing the customer ID is “username”. 
 

iv. You can access the website by this address in browser: http://localhost:8080 and log in using pre- 
created credentials:  
 
Username: labuser# (example labuser1) 
Password: same as username 

 
  

http://localhost:8080/
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v. Once you’ve logged in, check the variable in browser’s console by opening Developer Tools. In 
Chrome, you can use the keyboard shortcut (command + Option + J) or choose View > Developer > 
Developer Tools from the top menu bar. Once the developer tools window is open, click on the 
Console tab. Inside the console tab type: 
 
window.localStorage.getItem("username") 
 
Doing so will return the value of this variable. 

 

i. Now we can see, username is the variable in local storage that we can use to create the Data 
Element. 

Task 8: Creating the Data Element 

i. Go to Data Element tab, and click on Create New Data Element: 
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ii. Enter a name for Data Element. The extension should remain Core by default. 
iii. Select Data Element Type as Local Storage from the drop-down list. (you can also type local storage 

for it to appear). Local Storage item name is “username” (as we found out in previous task).  
 

 
 

iv. Leave all other settings as default and save the data element.  
 
Optionally, you can create another data element to capture page info in it. 
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Task 9: Defining Rule for firing Adobe Analytics call (Rule 1) 

IF event == Page bottom, THEN action  AA– set variables AND AA–  Send Beacon 
 

i. Go to Rules tab and click on Create New Rule: 

 

ii. You can name it anything you would like. Let’s name it “All Pages Bottom”. 
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iii. Under IF condition, we will add the event when we want the rule to fire. Click on the + sign to add 
event: 

 

iv. Extension should be Core, then Select the Event Type as Page Bottom from the drop-down list and 
click on Keep Changes. 

 
 

v. Then we’ll be back to the rules tab under same rule. Now we need to add actions under THEN for 
this rule. 
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vi. Click on the + sign under THEN, to define the action. 

 

vii. Under Action Configuration, select Adobe Analytics as extension, and Action type as Send Beacon. 
Leave all other settings as default. Then click on Keep Changes.  
 
Optionally you can create another action for setting AA variables. 
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viii. This Rule’s settings should appear like following: 

 

Outcome of this task: When the page finishes loading (Page Bottom), the Analytics Beacon will fire with 
the variables we assigned. 
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Task 10: Defining Rule to collect Customer ID using Experience Cloud Visitor ID service (Rule 2) 

IF event == Page Top, CONDITION == Logged in THEN action  Experience Cloud ID Service– Set Customer ID 

Note: The data source is already created for you. You can view the data source settings in AAM UI. 
Integration code for the data source is crm_id. To learn how to create a Data Source, check Addendum 3. 

Once we have Data Source ready we can create a rule to fire Visitor ID service call when the user logs in and 
collect their Customer ID (declared ID). 
 

i. In Launch, go to rules tab of your web property. Give this rule a name: All Pages Top Authenticated. 
ii. Under IF condition, click on + sign to add an Event 
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iii. For the event configuration, keep the extension as Core, and select event type as Library Loaded 
(Page Top) from the drop-down list, and click Keep Changes. 

 
 

iv. Now, under CONDITIONS, we need to add a condition to check logged in status of the site visitor. 
For this click on the + sign under CONDITIONS, then under Condition Configuration, the extension 
should be Core, and select Condition Type as Logged In from the drop down. 
 

v. Select the data element as Log in Element that we created in previous Chapter, and then click Keep 
Changes. 
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In Next step, we will be adding an action to grab Customer ID when the user signs in and collect that 
customer ID in our AAM Cross Device Data Source. 
 

vi. You’ll be back into your rule now, scroll down and under THEN click on the + sign to add an Action. 
Under Action Configuration, select Extension as Experience Cloud ID service from list.  

 
 

vii. Select Action Type as Set Customer IDs from the drop down. 
Enter the same Integration code for your Data Source that is crm_id 
 
In the value field, add the data element that we created in Chapter 2 (You can check the list of all 

available Data Elements by clicking on the icon  ). For Auth State, select “Authenticated”: 
 

 

  



 
 
 

25 | L768                     Implementing AAM with Customer ID sync using Launch 

Now click on Keep Changes and Save the rule. This rule’s exact settings should appear like this: 

 
 

Outcome of this task: When the user logs in, the Experience Cloud ID call will fire and sync Customer ID with 
Device ID.  
 
This call will have a parameter: d_cid_ic == integration code%01Customer ID 
An integration code is an alternate ID you can use instead of the Data Source ID 
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Chapter 4: Enabling Web Property: Adding Adapters, Environments and Library 
 
In this chapter, we will add an adapter, create environments and deploy a library in Launch. Next, we will 
implement our library on the website by adding the embed code. 

Task 11: Adding Adapter in Launch 

An “Adapter” refers to the destination(s) where you want to deploy your Launch libraries—on Adobe’s Akamai 
instance or on your own web servers. For this exercise we will create an Akamai Adapter. 
 

i. Click Adapters in the Property navigation, then click Create New Adapter:  

 
 

ii. Name the Adapter— “Akamai” and select the Akamai type from the dropdown and click Save:   
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Task 12: Creating Environments 

Launch introduces Development environments which allows you to create as Development builds as needed. 
For example, the Analytics implementation team can work in their own development environment, while the 
Target implementation team can work in their own development environment. They can work independently 
and merge their code later in the publishing process. 
  

i. Click “Environments” in the top navigation and then click “Create New Environment” under 
“Development” click “Select”:  

 
 

ii. Name your environment “Development 1,” select your “Akamai” adaptor, and then click “Create”:  

 
 

Note: The Create archive option is a feature used for self-hosting, which we will not be using in this 
Exercise. 
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iii. Note that as soon as you select the Adapter and hit the create button, the embed code for that 
environment is created and displayed.  Each environment will have its own unique embed code: 

 

iv. Click “Close”.  
v. Next, add a staging environment and a production environment (optional). However, for this exercise 

we only need a Development environment. 
vi. Once you are done, you should have your Environments listed (staging and production environment 

are optional for this exercise):   

 

Note: You can obtain the asynchronous embed codes by using the toggle. The toggle selection is not saved in 
the UI. For this activity, we will not be using async code.  
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 Task 14: Building Library 
 
In Launch, each change must be intentionally added to a library and then that library must be “built” in order 
for the changes to be pushed to the environment. 

These steps will guide you through adding library for Development environment: 

i. Go to the “Publishing” tab. Click the “Add New Library” button in the Development section 

 

ii. Name your library (e.g. “labuser1 library”). Map it to your “Development 1” environment. Click 
“Add All Changed Resources”, this will quickly add all your changes to the library.  
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iii. In the screenshot below, note that all your Rules, Data Elements, and Extensions now appear as 
“Changes to be Built”: 

 
 

iv. Click “Save” to save the library with all the changes. The last remaining step is to build the library.  
The yellow dot indicates that the library hasn’t been built.  Select the “Build for Development” 
dropdown option: 
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v. Once the library has successfully built, you will see the green status icon.  Launch will confirm that 
the library has been deployed to the environment before it changes the status icon to green. 

 

Task 13: Implementing Launch Embed Codes 

Now we will be implementing the Launch Embed Codes in our sample site. 
For each environment, there are two embed codes for synchronous deployments, the Header Embed Code 
and the Footer Embed Code. In this exercise, will be using Development environment’s embed code:   

i. Header Embed Code: The Header Embed Code should be implemented in the <head> element of all 
HTML pages. Typically, in actual sites you have one or several template files which control the 
<head> globally across the site. 
 

ii. Copy the header embed code and then go to this location on your Mac > Desktop > samplesite > 
open both the web pages one by one in Text Edit or Brackets, and add the head embed code just 
after opening of <head> element in HTML. This should be placed in both HTML files. 
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iii. The footer embed code remains same for all, so that is already placed for you. The footer embed 
code is placed just before the close of the </body> element. 

 

Task 14: Verify Adobe Analytics and Experience Cloud ID service call 

Now, we’ll test to see if our Launch property is loading and all the calls are firing as we expect. To do this, we’ll 
open the site in Chrome and refresh. For this exercise, it is recommended that you open the web page in New 
Incognito Window of Chrome. 

i. A new Incognito window can be launched by entering the keyboard shortcut cmd + shift + n key or 
by clicking File > New Incognito Window from the menu bar near the top of the screen. With 
developer tools opened in Chrome (Command + Option +J  or View > Developer > Developer Tools), 
access the sample site: http://localhost:8080 
 

ii. Go to Network Tab in browser, to verify if network calls are being fired for Adobe Analytics and 
Experience cloud ID.  

 

  

http://localhost:8080/
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iii. Also, check the response of AA call, and see if it has a response with DCS region and UUID. That 
means SSF is working fine.  

 
 

iv. With developer tools still opened, sign in as authenticated user using the credentials for this site: 
Username: labuser# (example: labuser1) 
Password: same as username 

 
v. After signing in, In the query parameters check the value of d_cid_ic. The value comprises a 

combination of the integration code and CRM ID. 
This call will have a parameter: d_cid_ic == integration code%01Customer ID 

 

This completes our basic implementation for AA, AAM with SSF and Experience Cloud ID. 
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For More Hands On 

 
Chapter 5: Onboarding offline data to Audience Manager via FTP/S3 (Optional) 
 
We often know even more about our customers than is available to us online. This data is most often stored 
“offline” in our CRM or database. Using AAM, we can now bring that data “online” in the form of traits. We 
then match those traits with our web data using the CRM or Customer IDs we set in the previous chapter. 

Task 15: Creating onboarded traits 

If we have some behavioral data available in our CRM for our customers, we can onboard this data 
and create some example traits. 

 
i. Go to Audience manager UI, from the application switcher at the top right corner. Then go to 

Manage Data  Traits. 
 

ii. Then click on Add new  Onboarded and you will get options to define onboarded trait: 
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iii. Create a trait named Credit Score, and we will qualify those users for this trait who have credit 
score above 7. So, the Trait Expression in Expression Builder is “creditscore” >= “7”. Click on Add 
Rule and Save. 

 
 

iv. Similarly, we can create another trait, named Qualification, with trait expression: qualification 
contains graduation. 

v. Expressions used in these traits will be used in our inbound file keyed off CRM IDs or Customer ID. 
 

Task 16: Creating inbound file for data onboarding 

i. Open Text Edit on your MAC, and enter CRM IDs (Customer ID that we grabbed to sync with device 
ID) that we have for this exercise (labuser1 to labuser95). You can add the same CRM ID that you 
have used to sign in to sample website. 

ii. Add the row in this format: <CRMID><Tab>”key”=”value”,”key”=”value” 
Example: labuser1  “creditscore”=”8”,”qualification”=”graduation” 

iii. Save this file on your desktop in with this file name: ftp_dpm<data source id>_<current unix 
time>.sync 

iv. Now, this file is ready and can be uploaded to the FTP-in or s3 inbound server to be processed and 
onboarded. After few hours (may take up to 24 hours), we will be able to see this file’s onboarding 
status and these onboarded traits will have a population. 

v. We can later create segments using real time and onboarded traits and use profile merge rules 
along with Recency and Frequency in our segments. 
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Chapter 6: Working with d_cts flag in DCS API call (Optional) 
 
We will be verifying that whether CRM ID or Device ID is qualified for intended traits and segments using DCS 
APIs. 
 

Task 17: Making the API call 

i. We will use a pair of Data Source Integration Codes (DSIC) and the CRM ID to check whether it is 
qualified for the intended traits and segments. 

ii. The demdex subdomain for our account is: aamlab.demdex.net, we can add following DCS 
parameters:  
 
d_cid_ic=<DSIC>%01<CRMID>  This is the data source integration code and CRM ID pair. 
 
d_rtbd=json  This required to get a JSON response from the DCS. 
 
d_cts=2   Returns segment IDs for the segments 
 

iii. Now our call should be like this:  
 
aamlab.demdex.net/event?d_cid_ic=<DSIC>%01<CRMID>& d_cts=2&d_rtbd=json 

 
Example DCS API call:  
http://aamlab.demdex.net/event?d_cid_ic=labuseric%01labuser10&%20d_cts=2&d_rtbd=js
on 
 

iv. Now we can make this call from our browser and get the JSON response from DCS. A sample 
response could look like the one below: 

 
 
This is end of your lab. Thank you very much for your attention. 

  

https://aamlab.demdex.net/
http://aamlab.demdex.net/event?d_cid_ic=labuseric%01labuser10&%20d_cts=2&d_rtbd=json
http://aamlab.demdex.net/event?d_cid_ic=labuseric%01labuser10&%20d_cts=2&d_rtbd=json
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Addendum 

1: Creating Report Suite in Adobe Analytics UI 
 

i. Access Adobe Analytics UI after signing into Experience Cloud. 
ii. In Adobe Analytics, go to Admin  Report Suites. Then click on Create New  Report Suite. 

iii. Fill in the required fields in New Report Suite. Click Create Report Suite. 
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2: Downloading Appmeasurement and Audience Management Module Library code 
 

i. In Adobe Analytics UI, click on Admin  Code Manager.  
ii. Then click on top option Javascript (new) 

 

iii. This will download a zip file with the name: AppMeasurement_JavaScript-2.7.0.zip 
iv. We can unzip this file and merge AppMeasurement.js and 

AppMeasurement_Module_AudienceManagement.js to form a single JS file. 
v. For this exercise, the final Appmeasurement.js file is already present on your MAC. Check the 

Assets folder on your desktop. 

  



 
 
 

39 | L768                     Implementing AAM with Customer ID sync using Launch 

3: Creating Data Source in Audience Manager 

Before we add a rule to collect Declared ID in Visitor ID calls, we should have a Data Source defined in AAM, 
that should be collecting these declared IDs. Follow the steps to create a Data Source in AAM UI: 

i. Click on the Experience Cloud application switcher and select Audience Manager. Alternatively, you 
can use this URL to sign into Audience Manager: http://bank.demdex.com 

ii. Once you are logged in, click on Manage Data  Data Sources  Click on + sign to Add New Data 
Source: 

 

iii. Then add the details for this Data Source: Name and Description. You can use same name as your 
seat ID, or Lab User#. 

 
iv. Give an integration code and make a note of this, as this needs to be used in Customer ID sync 

implementation. 
You can use labuser#ic (example: labuser10ic) 

  

http://bank.demdex.com/
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v. Select ID type from the drop-down list as Cross Device. Under Data Source Settings, check Inbound 
and select Customer ID: 

 

 

 
Links and Resources: 
 

• Adobe Audience Manager standard documentation: 
https://marketing.adobe.com/resources/help/en_US/aam/index.html 

• To continue the conversation and ask questions, visit our forums: 
https://adobe.com/go/aamcommunity 

• You can also use Twitter by following: @AdobeExpCare 

https://twitter.com/AdobeMktgCare
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