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Exercise Overview 
The following table provides a high-level overview of the activity and exercises, including 
estimated time to complete, contained in this guide. 

Activity / 
Exercise 

Summary Estimated 
Time 

Exercise #1 Team-based Development Experiences.  Students will be exposed to 
the built-in capabilities supporting team-based development, 
including checking in/out assets, synchronizing applications, and an 
overview of permissions. 

20 mins 

Exercise #2 Component-based Development.  Students will use various services 
and assets to create a simple application, which will be accessible in 
LiveCycle Workspace ES2. 

20 mins 

Exercise #3 Pre-populating forms with data.  Students will use built-in capabilities 
and preconfigured service and database to pre-populate a form. 

15 mins 

Exercise #4 Validation Reports and Record / Playback functionality.  Students will 
use built-in capabilities to validate, debug and troubleshoot their 
application.   

10 mins 

Exercise #5 Invoking LiveCycle Services.  Students will create an AIR application, 
using service discovery to invoke a LiveCycle service.  Invoking the 
same service via the REST API will also be included. 

10 mins 

Exercise #6 Creating a LiveCycle archive to take with you. 5 mins 
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Exercise 1: Team Development  
In this exercise you will begin by creating a LiveCycle application in LiveCycle Workbench, 
create folders in the application and add assets to those folders. You will experience the visual 
indicators associated with team development and asset status's (check-in/check-out) and 
version history.   

 

Objectives:  

By the end of this exercise you will be able to; 
 Use the wizards to create a new application, including a folder structure 
 Use the form and process wizard to create simple assets 
 Understand how check-in/check-out functions 
 Visualize team development 

 

Assets Provided:  

In addition to creating new assets, the following assets have been preconfigured for use in this 
exercise:  

1. Employee_Input_Form.pdf 
a. /MAX/Developing_Applications_Assets/1.0/forms/ 
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Tasks: 

Task 1: Log into the vmware image 

In this task, you will log into the vmware image using a dedicated account representing a 
member of a development team. 
 
1. Select Start->Shut Down. 
2. Select log off administrator and click ok. 
3. Press ctrl+alt+ins to invoke the windows login dialog. 
4. Log into the vmware image using the following credentials: 

 Username = "kbowman" 
 Password = "password" 

 
 

Task 2: Log into and configure the development environment 

In this task, you will log into Adobe LiveCycle Workbench ES2 as a member of a development 
team and configure your IDE to communicate with the LiveCycle server deployment. 
 
1. Double-click the Adobe LiveCycle Workbench short-cut on the desktop. 
2. Select File->Login. 

 
 
 
 

3. Select the Configure button to be directed to the Manage Configured Servers dialog box. 

4. Select the  button, which will trigger the display of the Adding New Server dialog box. 
5. Enter "localhost" into the Server Title field.  You'll notice the value you enter will be automatically 

replicated in the Host Name field. 
 

Note:   Kara Bowman has not configured her login information yet.  The following steps identify 
how to configure your installation of Workbench with the back end LiveCycle deployment. 
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6. Click OK to return to the Workbench login dialog. 
7. Provide the following credentials to log into Workbench: 

 Username: = "kbowman" 
 Password: = "password" 
 Log on to: = "localhost" 

 

 

Task 3: Get the Application Assets 

In this task, you will retrieve application assets from the server. 
 
1. In Workbench, select File->Get Applications.  This will display the Get Applications dialog listing 

all available applications. 
2. Select "MAX_Developing_Applications_Assets", expanding the folder. 
3. Select " MAX_Developing_Applications_Assets/1.0" and click OK.  This will retrieve a local copy 

of the application. 
4. Expand the various folders in the application structure.  Your view should be similar to the 

following diagram. 

Note:  You will be presented with a dialog indicating that a connection is being made to the 
server, localhost.  This is essentially retrieving the available services and their configurations. 
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Task 4: Check out a form for modifications 

In this task, you will check out a form from the application you acquired in the previous task. 
 
1. In the Applications view, expand the "MAX_Developing_Applications_Assets" folder structure to 

view the asset in the forms folder. 
2. Highlight the "Employee_Input_Form" file, right-click and select "Check Out". 
3. Double-click the "Employee_Input_Form" file.  You will be presented with a dialog similar to the 

image below, indicating the launch of Adobe LiveCycle Designer ES2. 
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Task 5: Modify, save, and check in the form 

In this task, you will modify and save the "Employee Information form". 
 
1. Select the "Dependents" text box, located in the "Employee Information" section in the top left-

hand side of the form. 
2. Double-click the text label and add a colon to the end of the text.  The updated text should read 

"Dependents:". 
3. Select the "Gender" text label, located to the right of the Dependents text. 
4. Double-click the text label and add a colon to the end of the text.  The updated text should read 

"Gender:". 
5. Select "File->Save". 

 
 

6. Select "File->Exit".  This will close Adobe LiveCycle Designer ES2 and return you to Adobe 
LiveCycle Workbench ES2. 

7. In the Applications view, highlight the "Employee_Input_Form" file, right-click and select "Check 
In". 

Task 6: Review the form versions 

In this task, you will review the version history for the "Employee Information form". 
 
1. In the Applications view, highlight the "Employee_Input_Form" file, right-click and select 

"History…" 
2. Review the version history for this form.  The Administrator user created the initial file and Kara 

Bowman has modified the latest version.   

 

3. Click the Close button. 

Note:  You will be presented with the Save As dialog if you haven't check out the file. 
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Exercise 2: Component-base Development  
In this exercise you will create a simple application, including a form and a process, which will 
be accessible via the Workspace interface. 

 

Objectives:  

By the end of this exercise you will be able to; 
 
 Use the wizards to create a new form. 
 Use the wizard to create a new process accessible via the Workspace interface. 
 Understand how the check-in/check-out functionality works. 
 

Assets Provided:  

No assets will be provided for this exercise, you will create the required assets. 
 
 

Tasks: 

Task 1: Create a new LiveCycle application structure 

In this task, you will create a new LiveCycle application and the appropriate structure. 
 
1. In Workbench, select File->New-> Application to display the wizard selection screen. 
2. Set the Application Name to "MAX_Developing_Applications" and click Finish. 

 

 

3. Expand the "MAX_Developing_Applications" application, right-click on 
MAX_Developing_Applications/1.0" and select New -> Folder. 

4. Add a folder called forms. 

Note: This will create a new application version in the Application view of the Process Design 
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5. Add a folder called processes.  At this point we have a basic application structure that contains 
two folders to store assets. 

 

 

Task 2: Create a new LiveCycle form template 

In this task, you will create a new LiveCycle form template using the wizard.   
 

1. Right-click on the forms folder and select New -> Form... to display the wizard selection screen. 

2. On the New Form dialog, set the Name to "StartForm". 
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3. Click Next. 

4. On the Specify form data model dialog, select the "No data model" radio button and click Next. 

5. On the Form usage dialog, in the Form Submission section, select the "From LiveCycle 
Workspace ES" check box and click Next.  

 

 

 

 

 

 

Note: This will launch Adobe LiveCycle Designer ES2.  You will be presented with the new form 
assistant wizard, which will guide you through the initial setup of your new form. 
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6. Select all the defaults.   

 

 

 

 

7. From the Object Library view, click and drag a text field object to the top center of the form 
layout. 

8. Add 2 additional text boxes below the previous one.  Your form template should reflect the 
following image. 

 

 
 

9. Save the form by selecting File->Save. 

Note:   As you selected "From LiveCycle Workspace ES" as the Form Submission type, a submit 
button and script have been inserted to handle the form bridge functionality between the form 
and the browse 
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10. Select File->Close. 

11. Select File->Exit to close Designer.  You will return to Workbench. 

 

Task 3: Check in the newly created form template 

In this task, you will check in the newly created form template. 
 
1. In the Applications view, right-click on the "StartForm" file and select  

"Check In".  This will upload the asset to the server. 

 

Task 4: Create a new LiveCycle process 

In this task, you will create a new LiveCycle process using the wizard.  You'll also be leveraging 
the form you created in the previous task to initiate the application from Adobe LiveCycle 
Workspace ES. 
 

1. Right-click on the processes folder and select New->Process... to display the New Process wizard. 

2. Set the name to "SimpleProcess" and click Next. 

3. On the Configure a start point dialog, select the "When a user submits a task in Workspace" 
radio button and click Next. 

 

 

 

4. On the Workspace Start point Configuration dialog, select "Use an Existing Form".  Select 
"StartForm" from the MAX_Developing_Applications/1.0/forms folder.  Your dialog should 
reflect the following image. 

Note: This option will allow you to initiate this simple process using the Workspace interface.
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5. Click Next. 

6. In the Workspace Category section, select "Create a New Workspace Category" and enter 
"Developing Applications". 

7. Set the Workspace Process Name to "Initiate the Simple Process". 

8. Enter a meaningful description in the Description section.  Your dialog should reflect the following 
image. 
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9. Click the Next button to review the configuration summary and click Finish.  If you are not in the 
Process Design perspective, you will be presented with a dialog to determine if you'd like to open 
an associated perspective.  Select Yes. 

10. The wizard will create a new LiveCycle process, including the Workspace endpoint.  

 

Note: The values you enter in the description and in the Workspace process name fields will be 
presented to the end user in the Workspace interface. 
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11. Double-click on the "Initiate the Simple Process" icon, setting focus to the Process Properties 
view.  Notice the options selected in the wizard have been preconfigured.  A variable, formData, 
has also been created for the process. 

12. In the Application view, right-click on MAX_Developing_Applications/1.0 and select Deploy.  

 

 

 

 
 

Note: You will be presented with a dialog to determine if you want to check in the files before 
continuing. 
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13. Select the "Check in all files" radio button and click OK. 

 

 

 

Task 5: Test your simple application 

In this task, you will use the Workspace interface to initiate your simple process.  This simple 
process will render the form you created earlier in this exercise.   

1. In a browser, navigate to the Workspace interface located at http://localhost:8080/workspace. 

2. Log in using the following credentials: 

 User ID = "kbowman" 

 Password = "password" 

3. Select the "Start Process" icon located on the Workspace landing page. 

 

 
 

4. Selecting the Developing Applications category will display the Simple Process in the right hand 
window.  

 

Note: This will check-in and deploy the application to the server.  Now, you can initiate the form 
from Workspace and submit it to LiveCycle. 
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5. Click on the card.  

 

 
 

6. Enter some information in the available text fields and click the Complete button.  This will submit 
the form back to LiveCycle and return you to the Start Process area of Workspace. 

 
Note: As Adobe Reader is the default PDF viewer on this image, the Reader Save Data Warning 
dialog will be displayed when you begin entering data. 
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Exercise 3: Workspace Form Pre-population 
In this exercise you will modify the simple process you created in the previous exercise to use 
an existing form, integrate with a pre-configured LiveCycle Service to pre-populate with 
employee data before being displayed to the end user in Workspace. 

 

Objectives:  

By the end of this exercise you will be able to; 
 
 Modify an existing process to use a different form 
 Create an action profile 
 Describe how to invoke an existing LiveCycle service from your process 
 Describe how to use assets from multiple applications 
 Deploy the application to the server 
 Test your modifications via the Workspace interface. 

 

Assets Provided:  

In addition to creating new assets, the following assets have been preconfigured for use in this 
exercise:  

1. aquo-ds.xml (database containing employee data) 
a. C:\Adobe\Adobe LiveCycle ES2\jboss\server\lc_turnkey\deploy 

2. Employee_Input_Form.pdf 
a. /MAX_Developing_Applications _Assets/1.0/forms/ 

3. Simple Process 
a. /MAX_Developing_Applications/1.0/processes/ 

4. EmployeeInputFormPrepareData 
a. /MAX_Developing_Applications_Assets/1.0/processes/ 
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Tasks: 

Task 1: Check out the required assets 

In this task, you will check out the assets required for this exercise.      

1. In Workbench, select the Applications view. 

2. Navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/forms, select the "Employee_Input_form" form, 
right-click and select "Check Out". 

3. Navigate to MAX_Developing_Applications -> MAX_Developing_Applications /1.0, right-click 
and select "Check Out". 

 

Task 2: Modify the Presentation & Data properties 

In this task, you will modify the form used by and existing process and create a new action 
profile for the form.      

1. Navigate to MAX_Developing_Applications -> MAX_Developing_Applications/1.0/processes, 
select "SimpleProcess", right-click and select "Open". 

2. Double-click the "Initiate the Simple Process" icon in the design canvas, and navigate to the  
Process Properties view. 

3. If not already expanded, select the arrow associated with the Presentation & Data property page 
to expand and display the available settings. 

4. Select the ellipses "…" button to the right of the Asset: property. 

5. In the dialog, navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/forms, highlight "Employee_Input_Form" and click 
OK. 

6. Select the  icon to the right of the Action Profile property.  This will display the Action Profile 
dialog box. 
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7. Select the  icon to create a new Prepare data process. 

8. Review the properties on this dialog.  The following image reflect the dialog you will be presented. 
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9. Click Cancel to return to the Action Profile dialog. 

10. Click the  icon to create a new Action Profile. 

11. Set the Name to "Pre-population", the Description to "Pre-populates the form…". 

12. Click the  icon associated with the Prepare data process property.   

13. Navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/processes, select 
"EmployeeInputFormPrepareData" and click OK. 

14. In the Default render process configurations section, click the box for "Reader Extend".   

 

 

 

15. Click OK. 

16. Save the SimpleProcess by selecting File -> Save. 

 

Note: All Reader Extensions credentials available on your LiveCycle ES server will be populated 
in the dropdown box. 
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Task 3: Review the EmployeeInputFormPrepareData process 

In this task, you will review the LiveCycle process that you associated with the action profile in 
the previous task.      

1. Navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/processes and open 
"EmployeeInputFormPrepareData". 

 

 
 

2. Double-click the Programmatic startpoint0 icon.  Notice the endpoint is configured for SOAP as 
opposed to the process you created earlier, which was configured for Workspace.   

3. Double-click the Query Single Row activity. 

4. In the Properties view, click the arrow beside the Input section to expand and display the 
properties. 

5. Select the ellipse "…" button associated with the *SQL Statement property.  This will launch the 
SQL Statement Info Editor dialog. 
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6. Click in the cell directly under the Test Value header, enter "hdouglas" and click the Test button. 

 

 

 

7. Click Cancel. 

8. Click the arrow beside the Output section to expand and display the properties. 

9. Select the ellipse "…" button associated with the *Data Mapping property.  This will launch the 
SQL Results Mapping Editor dialog.  Process variables have been associated with database 
column names. 

10. In the process, click the Update XML activity. 

11. Expand the Mapping property page by selecting the arrow to the left of the text Mapping. 

Note: Query Single Row has been configured to query a local employee database.  The info 
editor is a great way to validate your query statements. 
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12. Select the  icon to display the XPath Builder dialog. 

 

 
 

13. Click Cancel. 

14. Close the "EmployeeInputFormPrepareData" process.  
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Task 4: Check in the modified assets and deploying the application 

In this task, you will check in the modified assets and deploy the application. 

1. Navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/forms, right-click on "Employee_Input_Form", and 
select "Check In". 

2. In the Applications view, navigate to MAX_Developing_Applications -> 
MAX_Developing_Applications/1.0, right-click and select "Check In". 

3. In the dialog, select the "Check in all files" radio button and click OK. 

4. Expand MAX_Developing_Applications, select MAX_Developing_Applications/1.0, right-click 
and select "Deploy". 

 

Task 5: Test the application 

In this task, you will use the Workspace interface to initiate your modified process, using a 
different form and an existing LiveCycle service to prepopulate the form with employee data 
from a database.  

1. In a browser, navigate to the Workspace interface located at http://localhost:8080/workspace. 

2. Log in using the following credentials: 

 User ID = "kbowman" 

 Password = "password" 

3. Select the Start Process icon located on the Workspace landing page. 

4. Selecting the Developing Applications category will display the Simple Process in the right hand 
window.  

5. Click on the card. This will load the "Employee Information form", pre- populated with employee 
information. 
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6. Click the Complete button.  This will submit the form back to LiveCycle, returning you to the Start 
Process area of Workspace. 
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Task 6: Use the Archive Wizard 

In this task, you will use the Archive Wizard functionality to merge data submitted by the user 
with the Employee_Input_Form, creating a PDFA version of the document that will be saved 
to the Content Store. 

1. In the Applications view, navigate to MAX_Developing_Applications -> 
MAX_Developing_Applications/1.0/processes, highlight "SimpleProcess", right-click and select 
"Check Out". 

2. Double-click the "SimpleProcess" process to display in the design editor. 

3. In the toolbar located across the top of the design canvas, select the  icon and drag onto the 
design canvas.  This will display the Archive Wizard dialog to you. 

 

 

4. Select the Form: radio button and click the associated  icon. 



Page 30 of 55

 Developing Applications using Adobe LiveCycle Workbench ES Next 

 

 

5. Navigate to MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/forms, highlight "Employee_Input_Form", and click 
OK. 

6. In the Conversion options section, select the PDFA radio button. 

7. Select the "Save to Content Store" checkbox and click Next. 

8. On the Content Services Settings panel of the Archive Wizard dialog, click the  icon associated 
with the Space Path option. 

9. In the Select space dialog, highlight the Developing Applications entry and click OK. 

 

 
 

10. Enter "Employee_Input_Form_Data.pdf" in the node name field and click Next.  The summary 
dialog should be similar to the image below. 
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11. Review the summary information and click Finish. 

 

 

 

12. Save, Check In and Deploy the application. 

 

 

 

 

 
 

 

Note:  Once you click Finish, all of the required services will be added to the design canvas, 
preconfigured based on the options provided in the Archive Wizard dialog.
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Task 7: Test the application and validating the asset in Contentspace 

In this task, you will use the Workspace interface to initiate your modified process and upon 
submission, you'll add the submitted form to Contentspace. 

1. In a browser, navigate to the Workspace interface located at http://localhost:8080/workspace. 

2. Log in using the following credentials: 

 User ID = "kbowman" 

 Password = "password" 

3. Select the "Start Process" icon located on the Workspace landing page. 

4. Selecting the Developing Applications category will display the Simple Process in the right hand 
window.  

5. Click on the card. This will load the "Employee Information form", pre-populated with employee 
data. 

 

 
 

6. Click the Complete button.  This will submit the form back to LiveCycle, returning you to the Start 
Process area of Workspace. 
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7. In the browser, navigate to the Contentspace interface located at  
http://localhost:8080/contentspace. 

8. Log in using the following credentials: 

 User Name: = "kbowman" 

 Password: = "password" 

9. From the left-hand navigation, click on Company Home. 

 

 
 

10. Select the hyperlink associated with the Developing Applications space.  The result of merging 
the submitted data with the "Employee Information form", converted to PDFA will be added to the 
Deploying Applications space. 
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11. Click Employee_Input_Form_Data.pdf. 

12. Validate the form contains the submitted data and the information banner states "You are viewing 
this document in PDF/A mode.  Similar to the following image. 
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13. Close the browser. 
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Exercise 4: Validation Reports and Record / Playback Functionality 
In this exercise you will review the built in functionality to quickly identify, resolve and test 
your applications and assets.  Validation reports, and record & playback functionality provide 
you with a wide range of debugging capabilities.  

 

Objectives:  

By the end of this exercise you will be able to; 
 
 Describe the value of the validation report 
 Configure a process to record 
 Execute the playback of a recording 

 
 

Assets Provided:  

In addition to creating new assets, the following assets have been preconfigured for use in this 
exercise:  

1. Employee_Input_Form.pdf 
a. MAX_Developing_Applications_Assets -> 

MAX_Developing_Applications_Assets/1.0/forms 
2. FullNameBuilder 

a. MAX_Developing_Applications_Assets -> 
MAX_Developing_Applications_Assets/1.0/processes 
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Tasks: 

Task 1: Modify a process to generate a warning when validated 

In this task, you will modify SimpleProcess to include a variable, which will not be assigned in 
order to generate an entry in the Validation Report view.  The validation report will identify 
any warnings or errors for the applications you have in your Applications view.  
 

1. In the Applications view, navigate to MAX_Developing_Applications -> 
MAX_Developing_Applications/1.0/processes, select "SimpleProcess", right-click and select 
"Check Out". 

2. Double-click the "SimpleProcess".  This will launch the process design in the canvas. 

3. Select the Variables view, click the   icon.  This will display the Variable dialog box. 

4. Set the Name to "Validation", the Type to "string".  Your variable settings should reflect the 
following diagram. 

 

 



Page 38 of 55

 Developing Applications using Adobe LiveCycle Workbench ES Next 

 

 

5. Click OK to return to the editor. 

6. Save the modified process. 

7. In the Applications view, highlight the "SimpleProcess" process, right-click and select "Validate". 

 

 

 

8. Double-click on the "Validation Report" tab to maximize the view.   

 

 
 

9. Double-click on the "The variable 'Validation' is not referenced in the process 
'MAX_Developing_Applications/processes/SimpleProcess'" entry.  This will direct you to the 
process where the warning has been identified.  Alternatively, pressing F1 while the message is 
highlighted will launch the help to the specific topic. 

10. With focus on the "SimpleProcess", highlight the "Validation" variable in the Variables view, right 
click and select "Delete Variable". 

11. In the Applications view, navigate to MAX_Developing_Applications -> 
MAX_Developing_Applications/1.0/processes, select "SimpleProcess", right-click and select 
"Check In".   

12. Validate again and you'll notice the previous warning has been removed from the Validation 
Report view.  

 

 

 

Note: This will trigger a validation of all assets in all the local application folders.  The results will 
be displayed in the Validation Report view. 
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Task 2: Enable Record functionality 

In this task, you will configure the EmployeeInputFormPrepareData process to record the next 
time the process is invoked. 
 
1. Navigate to MAX_Developing_Applications_Assets -> 

MAX_Developing_Applications_Assets/1.0/processes  
2. Select the "EmployeeInputFormPrepareData" process, right-click on "Record and Playback" and 

select "Start Recording". 
 

 
 

 

 
 

 
 

Note: This will apply a visual indicator on the process name and record all activities, including all 
values of the variables utilized in this service. 
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Task 3: Test the application to trigger the recording 

In this task, you will use the Workspace interface to initiate the SimpleProcess, which will 
invoke the EmployeeInputFormPrepareData service that has been configured to be recorded.  

1. In a browser, navigate to the Workspace interface located at http://localhost:8080/workspace. 

2. Log in using the following credentials: 

 User ID = "kbowman" 

 Password = "password" 

3. Select the "Start Process" icon located on the Workspace landing page. 

4. Selecting the Developing Applications category will display the Simple Process in the right hand 
window.  

5. Click on the card. This will load the "Employee Information form", pre-populated with employee 
information. 

6. Click on the Complete button to submit the request to LiveCycle for processing. 

 

Task 4: Review the recording 

In this task, you will review the recording that was created for the 
EmployeeInputFormPrepareData service.  
 
1. In Workbench, navigate to MAX_Developing_Applications_Assets -> 

MAX_Developing_Applications_Assets/1.0/processes  
2. Select the "EmployeeInputFormPrepareData" process, right-click on "Record and Playback" and 

select "Stop Recording". 
3. Select the "EmployeeInputFormPrepareData" process, right-click on "Record and Playback" and 

select "Playback".  You will be presented with the Play Process Recording dialog similar to the 
following image. 
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4. Highlight the latest entry in the dialog box and select OK.  The EmployeeInputFormPrepareData 
process will be displayed in the design canvas with a few more options than in the regular design 
canvas. 
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5. Click the play button,  , and simply watch the progression.   
6. Once the playback has completed, use the slider to return to the beginning of the recording. 

 

 
 

7. Click the   button, to move the execution to the next step.  The Query Simple Row activity 
should be highlighted.  In the Variables view, notice that all the variables are also highlighted and 
contain values or an ellipse button. 
 

 

Note: In the following steps you will play the recording. The playback will execute quickly, 
therefore additional steps have been included to play the entire recording first, providing you with 
a visual representation of what to expect.  This step will be followed by instructions to pause the 
recording and view variable values. 
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8. In the Variables view, click the <ellipses> icon associated with the taskContext variable.  You will 
be presented with a dialog similar to the following image, which contains the content currently 
assigned to the variable. 

 

9. Click the Close button. 

10. Close the canvas by selecting the  located in the top right-hand corner of the canvas. 
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Exercise 5: Invoking LiveCycle Services 
In exercise 2, you created a simple application using the Workspace interface to invoke the 
process.  In this exercise you, will review the pre-configured process, which you will invoke 
using the Remoting and REST programmatic start points.  You will create an AIR desktop 
application using Flash Builder to invoke the service using the Remoting endpoint and you 
will create a custom query string in the browser to invoke the same service using the REST 
invocation method. 
 

Objectives:  

By the end of this exercise you will be able to; 
 
 Describe how service discovery works 
 Configure a Flex project to invoke a LiveCycle service 
 Test the AIR desktop application 
 Describe the query string parameters to invoke a LiveCycle service using the REST programmatic 

start point 
 

 

Assets Provided:  

In addition to creating new assets, the following assets have been preconfigured for use in this 
exercise: 

1. FullNameBuilder process 
a. MAX_Developing_Applications_Assets -> 

MAX_Developing_Applications_Assets/1.0/processes 
2. Data Services client libraries 

a.  C:\Adobe\Adobe LiveCycle ES2\LiveCycle_ES_SDK\misc\DataServices 
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Tasks: 

Task 1: Review the FullNameBuilder process 

In this first task, you will review the pre-configured FullNameBuilder process, which will be 
used for both Remoting and REST programmatic start point later in this exercise. 

 

1. In the Applications view, navigate to MAX_Developing_Applications_Assets ->  
MAX_Developing_Applications_Assets/1.0/processes 

2. Double-click the the FullNameBuilder process.  This will open the process in the design canvas. 

 

 
 

 

 

 

3. Log out of Workbench by selecting File -> Logout.  You will be presented with the log out dialog. 

4. Click OK. 

5. Close Workbench by selecting File -> Exit. 

 

 

 

 

Note: This process is configured with 2 input variables; first name and last name.  The process will 
concatenate these values.  The output of the service will be the concatenated value. 
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Task 2:  Create a new Flex application 

In this task, you will create a new Flex application using the Flash Builder plug-in for eclipse. 
 
1. Double-click the Adobe Flash Builder Plug-in Beta Eclipse Launcher shortcut located on the 

desktop. 
2. You will be presented with the Eclipse Workspace Launcher dialog box, requesting you Select a 

workspace.  Click OK to accept the default location. 
 

 
 

3. Once Flash Builder is loaded, select File -> New -> New Flex Project.   
4. Set the Project name to "Developing_Applications". 
5. In the Application type section, select the Desktop (runs in Adobe AIR) radio button and click 

Finish.  The new application will be displayed in the Package Explorer view. 
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Task 3: Configure the Flex Build Path properties 

In this task, you will configure the Flex Build Path properties for the Developing_Applications 
project you created.   
 
1. Highlight the Developing_Applications project, right-click and select Properties.   
2. In the left-hand side of the dialog, highlight Flex Build Path.  This will display the Flex Build Path 

information in the right-hand side of the dialog. 
3. Click the Library Path tab. 
4. Click the Add SWC Folder button.   
5. Navigate to C:\Adobe\Adobe LiveCycle ES2\LiveCycle_ES_SDK\misc\DataServices, highlight the 

Client-Libraries folder and click OK.  You will be returned to the Library path tab, your properties 
should resemble the following image. 
 

 
 

6. Click OK to close the Properties dialog.   
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Task 4: Configure the Data/Service properties 

In this task, you will use the new service discovery capability in Flash Builder to connect to 
LiveCycle ES server.   

 
1. In the right hand window, select the Design tab associated with the 

Developing_Applications.mxml window. 
2. Select the Data/Services tab, located directly below the Design layout. 
3. Click the Connect to Data/Service… hyperlink.  The dialog presented resembles the following 

image. 

 

4. Select LiveCycleES and click Next.  A dialog indicating the requirement to connect to a LiveCycle 
Server will be displayed. 

5. Click the Click here to login hyperlink to display the login dialog for LiveCycle ES2. 
6. Click the Configure… button. 
7. Add a new server, setting the Server Title: and Hostname: properties to "localhost".   
8. Click OK to return to the Manage Configured Servers dialog.   
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9. Click OK to return to the login dialog. 
10. Log in using the following credentials: 

 Username:  "kbowman" 
 Password:  "password" 
 Log onto:  "localhost" 

11. Click the Login button.   

 

 

 

 

12. In the Search options section, enter "builder" in the Find field and click the Search button.  You 
will be returned a single result in the Service selection section, similar to the following image. 

 

Note: To reduce the amount of results, the next step will identify a specific keyword for the service 
we want.  If no key word is identified and "Show only Flex Remoting services" check box is 
deselected all available services will be returned in the Service selection section. 
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13. Click the Next button.  In the LiveCycle Service Operations section, the invoke operation 
information, for the FullNameBuilder service, which identifies 2 input variables; FirstName and 
LastName, both of type String will be displayed.  

14. Click the Finish button.  This action will create a new package called 
com.adobe.idp.workflow.dsc.service in the Developing_Applications project, which contains the 
auto generated code to communicate with LiveCycle ES.   
 

 
 

Task 5: Generating and modifying the form for the desktop application 

In this task, you will generate and modify the form that is associated with your desktop 
application.  

 
1. In the Data/Services tab, right-click on the invoke operation and select Generate Form. 
2. Accept the defaults in the Generate Form dialog and click Next. 
3. Accept the defaults in the Property Control Mapping dialog and click Finish.   

 
 
 

4. In the Source view, find the layout property on line 2.  Change the value from "absolute" to 
"vertical". 

5. Select File -> Save. 

Note: The following instructions have been included to make the form more esthetically pleasing. 
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Task 6: Test the desktop application 

In this task, you will test your desktop application that was created in the previous task.  
 

1. In the Package Explorer view, highlight the Developing_Applications project, right-click and select 
Run As -> Desktop Application. 

2. In the application, enter your first and last name to the available fields and click the Invoke 
button. 

 

 

3. Use the following credentials to authenticate: 
 User name:  "kbowman" 
 Password:  "password" 

4. Click OK.  The values you entered in the FirstName and LastName fields have been concatenated 
and displayed in the Invoke field, similar to the following image. 
 

 
 

5. Close the Desktop Application by selecting the X located in the top right-hand side. 
6. Close Flash Builder by selecting File -> Exit. 

 

Note: As we did not configure any authentication in the application, you will be displayed a 
Connect to localhost dialog. 
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Task 7: Identify the REST Invocation URL for the FullNameBuilder service 

In this task, you will review the format to invoke the FullNameBuilder service using the REST 
start point. 
 
1. Launch and minimize notepad.  You will use this in step 9 to paste the REST Invocation URL. 
2. In the browser, navigate to the LiveCycle Administration Console, http://localhost:8080/adminui.  
3. Log in with the following credentials: 

 User ID:  "kbowman" 
 Password:  "password" 

4. Click the Login button. 
5. Navigate to Services -> Applications and Services -> Service Management. 
6. In the Name: field enter "builder" and click the Filter button.   
7. MAX_Developing_Applications_Assets/processes/FullNameBuilder:1.0..  This will direct you to 

the Endpoints tab listing all available invocation methods for this service. 
8. Select the hyperlink associated with the Default REST Endpoint.  You will be directed to the 

property page. 
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9. Copy the REST Invocation URL, 
http://localhost:8080/rest/services/MAX_Developing_Applications_Assets/processes/FullNameBu
ilder to notepad. 

10. Return to adminui and click the Close button on the Endpoint page. 
 
 

Task 8: Test the REST Invocation Endpoint 

In this task, you will create a custom query to test the REST invocation endpoint for the 
FullNameBuilder service. 
 
1. With the REST Invocation URL in Notepad, add the following text to the end of the URL: 

 "?FirstName=EnterYourFirstName&LastName=EnterYourLastName" 
 
 
 

2. Copy the entire URL, paste in the browser address field and hit the Enter key.   
3. Enter the following credentials in the authentication dialog: 

 User Name: "kbowman" 
 Password: "password" 

4. Click the OK button.  You should be displayed the FirstName and LastName concatenated. 

 

5. Close the all applications. 

Note:  Replace EnterYourFirstName and EnterYourLastName with your information. 
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Exercise 6: Create a LiveCycle Archive file  
In this exercise you will create a LiveCycle Archive file that you can export from the pre-
configured environment and take with you. 
 

Objectives:  

By the end of this exercise you will be able to; 
 
 Create a LiveCycle Archive file. 

 
 

Tasks: 

Task 1: Create a LiveCycle Archive file 

In this task, you will create a LiveCycle Archive file, containing all the preconfigured and newly 
created/modified assets covered in this lab. 

 

1. Log into Workbench using kbowman's credentials. 

2. In the Applications view, expand MAX_Developing_Applications_Assets, highlight 
MAX_Developing_Applications_Assets/1.0, right-click and select Create LiveCycle Archive. 

3. Ensure Create a new archive file. Is selected and click Next. 

4. In the Archive Properties panel, select the check boxes associated with 
MAX_Developing_Applications and the MAX_Developing_Applications_Assets options. 

 

 

5. Click the ellipse button associated with the Local file system destination. 

6. Provide a meaningful name, MAX_DevAppsWorkbench, and save to the desktop. 

7. Click the Save button.  Your configuration should resemble the following image. 

Note:  Selecting the main folder will automatically select the subfolders.
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8. Click the Finish button. 

9. Click OK in the Export Success dialog. 

10. Using Windows Explorer, navigate to the desktop and copy the MAX_DevAppsWorkbench.lca file. 

11. Navigate to My Network Places -> Entire Network -> Vmware Shared Folders -> .host -> Shared 
Folders -> share and paste the file. 

 

 

 

Note:  The lca file containing the pre-configured assets and the assets you created during this lab is 
now available on the host machine.   The employee database and the datasource file, aquo-ds.xml, 
in C:\Adobe\Adobe LiveCycle ES2\jboss\server\lc_turnkey\deploy folder, are the only assets not 
included in the lca. 


